Polaris ATV Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
its been a couple weeks since i've been on here but, as i mentioned in the past my 97 sportman 500 doesn't have the low end and top end it should have. and it doesn't rev high enough. a couple weeks ago i said i thought we found the problem, because we put liquid gasket on the carb adapter and it was better, but i ordered a new adapter and siliconed around it and, it is no good still! it also seemed abit better with the airbox off, but the filter is clean and see nothing wrong there. i am at a stand still, as to what to try next, i'm debating whether or not to take it to a new dealer already!

Heres a review of what we have done already:
-new camshaft/rockers
-adjusted valves
-checked timing
-cleaned fuel tank/new lines
-cleaned carb/new needle and seat
-checked for plugged exhaust
-clutch work
-new belt
-new carb adapter

any more ideas would be great, i'm getting sick and tired of it already!
 

·
Registered
Joined
·
38 Posts
Try this

Hi there, Did you happen to play with the idle screw/air screw? is it idling? That might be something to look at. It sound's like carb issues to me- i could be wrong. Also is the slide tight in side of the carb? If the slide is loose (worn out) you might be getting to much air-messing up air/fuel mix. This happen to a buddy of mine, but it was on a yamaha. Couldn't get to run right, found out that it was the slide-had to replace the carb in the end. Hope this helps.
 

·
Registered
Joined
·
263 Posts
Take a look at your original post on this topic. Some people mentioned some things to look at and I don't see them on your checklist.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #6
we've fiddled with the air screw a few times now, doesn't help much. it idles fine as well. we did try checking the etc, but i'm not sure if we disconnected the right wires because it seemed to be still working after. not totally sure if we checked diaphragm, i'll ask my dad about it though.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #9
clutch should be good, the dealer, and my dad and me went thorugh it. it seems to be working fine.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #13
not really but it seems to work okay, and i'd think the dealer would've looked at it, they put new buttons in the primary.
 

·
Registered
Joined
·
2,412 Posts
What buttons in the primary? Weights and spring.

Take the secondary apart and look at the helix and the buttons and make sure it's preloaded 1/4 turn counter clockwise
 
1 - 14 of 14 Posts
Top