Polaris ATV Forum banner
41 - 46 of 46 Posts

·
Registered
97 Polaris 500 sportsman 4x4 Indepedent shaft drive, 2000 Honda 450S foreman
Joined
·
621 Posts
I have a Fluke 218 ADC test meter, you need 4,512 ohms on the brown wire with yellow stripe at the front diff when at a 45 degree downhill angle and engaged in 4x4 ADC
Haha i have a fluke 87 that I’ve had about 20 years..120$ to calibrate it, think I paid in ballpark 300-400$ worth every penny
 

·
Registered
Joined
·
649 Posts
Discussion Starter · #42 ·
Well, all I can say is this. I've got about 3000 miles on my stuff so far, have ran only Amsoil since the first service and have had ZERO issues with the ADC. I've been down some pretty steep stuff without using my brakes, and it's never once failed me. So still not sold on the oil causing the issue...
I wish I knew what the deal was that I and some other people have a problem with Amsoil and some say it works fine.
All I can say for 100% sure that if I get a new front gear case Amsoil won't be used.
 

·
Registered
Joined
·
649 Posts
Discussion Starter · #43 ·
Check out the older style ADC. They have clutch packs similar to a wet clutch in a dirt bike with stacks of plates in a cage on the output hubs #2. If you don't keep the oil clean, they get worn and will start grinding when ADC is activated. Wear of the fiber plates is why the oil gets dark pretty quick if you use ADC a lot.
Polaris Hub Kit, Genuine OEM Part 3235331, Qty 1 | eBay
View attachment 167959
Yes my ADC is no doubt used up because I replaced my oil almost every ride and it was black every time but now it's coming out almost clean.
 

·
Premium Member
2021 Can Am 1000 XMR, 2019 570 EPS, 2021 CFMOTO 600
Joined
·
186 Posts
Ive been using amsoil in mine since new. 2019 850 sp and 19 570sp never had any issues with the adc with the amsoil. Couldnt imagine what wouldve caused that unless something was wrong already.
 

·
Registered
Joined
·
649 Posts
Discussion Starter · #45 ·
Ive been using amsoil in mine since new. 2019 850 sp and 19 570sp never had any issues with the adc with the amsoil. Couldnt imagine what wouldve caused that unless something was wrong already.
Yes it's very puzzling that I and others have a problem with Amsoil and some don't.
I first tried Amsoil when my Sportsman was new and was working fine and tried the Amsoil and it quit working right and put Polaris oil back in and it works fine but I tested several times back and forth and had the same problem with Amsoil.
It keeps bugging me so I just go ahead and pull it out and see what is this crazy Polaris front gear case because I can't find a straight answer or video showing what's in this year model.
 

·
Premium Member
19’ 850SP Camo. MtAiry Maryland
Joined
·
3,306 Posts
Yes it's very puzzling that I and others have a problem with Amsoil and some don't.
I first tried Amsoil when my Sportsman was new and was working fine and tried the Amsoil and it quit working right and put Polaris oil back in and it works fine but I tested several times back and forth and had the same problem with Amsoil.
It keeps bugging me so I just go ahead and pull it out and see what is this crazy Polaris front gear case because I can't find a straight answer or video showing what's in this year model.
That sounds good, let us know 😊
 
41 - 46 of 46 Posts
Top