Polaris ATV Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 · (Edited)
I was washing the 850 and I found this laying on the frame anyone care to guess what it is cause I have no clue.
 

Attachments

·
Registered
Joined
·
195 Posts
Is it metal? When the universal joint broke loose on my Outty it left fragments such as that on the ground.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #3 ·
Yes its metal its very light weight.
 

·
Registered
Joined
·
101 Posts
It looks like aluminum. Are you missing any chunks off any of the aluminum casings from your machine?

seabee78
 

·
Registered
Joined
·
1,891 Posts
it looks cast aluminum..what ever area you found it I would start looking them areas over that are cast...it looks like something rubber may have been rubbing it by the black circular marks...
 

·
Registered
Joined
·
1,181 Posts
Something you picked up on the trail???
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
I found it under the drive shaft going into the front diff. Problem is I don't know what it looks like normally looks to have been a complete circle at one point in time. It is possible that I could had picked it up on the trail yesterday
 

·
Registered
Joined
·
1,159 Posts
I would look your atv over make sure no oil leaking anywhere. I am curious what this piece of aluminum is from?

Sent from my SCH-R970 using Tapatalk
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #9 ·
Not a spot of oil anywhere
 

·
Registered
Joined
·
333 Posts
Damn! I know exactly what that is, I found one too!
It's from your winch. I busted two Polaris winches already.
unspool your cable and have a look
 

Attachments

·
Registered
Joined
·
1,519 Posts
Damn! I know exactly what that is, I found one too!
It's from your winch. I busted two Polaris winches already.
unspool your cable and have a look
You da man! :rock_dj:
 

·
Registered
Joined
·
145 Posts
Damn! I know exactly what that is, I found one too!
It's from your winch. I busted two Polaris winches already.
unspool your cable and have a look
Nice job RangerBob!!

For the OP, this is classic bad news/good news. Bad news is that it's from your machine; good news is that it is not power train related.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #13 ·
Thank you for your help Rangerbob316. Does this mean my winch is shot now?
 

·
Registered
Joined
·
333 Posts
I did because mine was under warranty at the time. It still worked fine. I'm sure your seal is jeopardized now though.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #15 ·
This is why it busted that aluminium piece. Dang mud soaked sxs
 

Attachments

·
Registered
Joined
·
125 Posts
Discussion Starter · #16 ·
Here is another pic. Sxs was stuck for 3 hrs
 

Attachments

·
Registered
Joined
·
944 Posts
Pretty amazing that was winched out and up. Would have been a good spot for a snatch block.....or two.
 

·
Registered
Joined
·
1,181 Posts
Well that sucks!!! At least it is not part of the engine or trans casting. What make of winch it is??
 

·
Registered
Joined
·
460 Posts
Wow, that looks pretty rough!
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #20 ·
Pretty amazing that was winched out and up. Would have been a good spot for a snatch block.....or two.
We didnt have a snatch block but in the 1st pic i had a 700 grizzly attached to me. We were both pulling him. Rookie mistake i was pulling at an angle in 1st pic then switched to a straight on pull. We tried to pull him out backwards but with 3 wheelers but he wouldnt budge at all. So had to pull him out the hard way.
 
1 - 20 of 29 Posts
Top