Polaris ATV Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, I'm new to the forum and I have looked everywhere for a solution to my problem. It's an 04 ATP 500 ho. Manufactured 5/03. The speedometer recently went dead and then comes back on once in a while like there's a short.

Checked the wiring and all, tore it all apart and found all wires are fine. The 4wd doesn't seem to work whether it's on or off, and I will make sure after work today if the light comes on.

Where could this problem start? Are these known for bad speedos? Thanks anyone who can help
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
29 Posts
I have a 2004 ATP 500HO as well as a 2011 850 Touring. I bought my 04 brand new and have used it for the last 8 years fromm 2004 to 2012 almost dailey in my surveying practice. I will almost put money on it that somewhere in the headlight pod you have a cracked wire. This is my only beef with Polaris, in particular the earlier bikes is the wiring in the pod is crap. I have had to splice and repair mine with the exact symptoms you describe probably 3 times over the years. Take the top off the headlight pod and start the bike and start wiggling wires. It's there I'm almost certain.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thank u

Thank u guys very much I'll look into it when I get home and let u know what happens.

The transmission is having problems as well.. Might be a known problem I'm not sure.. When you try to hit reverse with the shifter it feels like something is really loose in there and doesn't have that crisp notch it used to fall into for each gear. Same with the others but mostly reverse is really hard to find. What would this be? I have to wiggle the shifter until it locks in. Any ideas? Thanks again!
 

·
Registered
Joined
·
29 Posts
Where the shifter dog is on the side of the transmission inside that there is a a half moon shaped gear with teeth on it. It tends to get teeth knocked off or chipped making it harder to get into gear. I had mine fail and could only get it in reverse. Had to0 back up 2km's to the trailer. Not hard to replace.
 

·
Registered
Joined
·
98 Posts
Certainly check the wiring as mentioned. If the speedo dies, it'll affect the 4wd as mentioned.

Had a similar issue with one of my ATP's as well.
 

·
Registered
2007 500x2 le
Joined
·
850 Posts
Hey my old sportsman 400 spedo did the same thing turned out to be the speed sensor on the fron right spindle
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Ugh

We'll guys I tore the whole pod apart and found no cracks or wear in the wires. Still working only when it wants to, seeking like there still has to be a some short somewhere. What is this speed sensor on the front right spindle? How would that effect the whole cluster to go on and off?

And another thing. I just noticed the cv boots right before the rims are ripped too! I've looked to find what parts I need to repair it and I don't know if I just need the boot itself? Do you need to split it? If so then would I need new shafts? It would be so much easier if someone could just put a link to the parts that I need to order for this mess. I don't have the experience of knowing what parts are good and what I need exactly. Thank u guys again this is a great forum!
 

·
Registered
2007 500x2 le
Joined
·
850 Posts
Hey sorry I missed the part on ur whole assembly shuts off I was thinking just the spedo check the circuit breakers they are in black rubber pouch under the front cover they tend to get moisture in them and rust and cause all sorts of issues I ended up discarding the rubber pouch altogether and mounted to the frame or a shield? Can't remeber but my spedo would quit randomly
 

·
Registered
Joined
·
1 Posts
Where the shifter dog is on the side of the transmission inside that there is a a half moon shaped gear with teeth on it. It tends to get teeth knocked off or chipped making it harder to get into gear. I had mine fail and could only get it in reverse. Had to0 back up 2km's to the trailer. Not hard to replace.
I’m having the same issues with finding the gears so I’m certain it’s this part you speak of, can you please tell me the name of this part or part number so I can get one ordered
 
1 - 14 of 14 Posts
Top