Polaris ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
new to me 600 sportsman the awd light only comes on when turning sharp right or left and never when backing up any help as why ? seems to lock front axel when light does come on ,never when backing up
 

·
Registered
Joined
·
2,412 Posts
Change the fluid in the front diff or in the hubs depending on wht year it is. Soiled like fluid is dirty or low that's why works when your turning sometimes.
 

·
Registered
Joined
·
2,412 Posts
then it sounds like you have a broken wire someplace
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
thanks for the help . will check it out .just a thought but why would it not trun the awd light on when backing up . sorry but this the first polaris for me
 

·
Registered
Joined
·
7,464 Posts
just a thought but why would it not trun the awd light on when backing up
In reverse = rev-limiter & no AWD, unless you push the yellow "override" button (left hand, lower control). There is a "mod" that can be done to eliminate this "feature"!!

Try down load the manual for your atv online and review this information is correct to your model/year, but that's how it works on my 2012.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
just a thought but why would it not trun the awd light on when backing up
In reverse = rev-limiter & no AWD, unless you push the yellow "override" button (left hand, lower control). There is a "mod" that can be done to eliminate this "feature"!!

Try down load the manual for your atv online and review this information is correct to your model/year, but that's how it works on my 2012.
what is the mod for override button sound like that is a pain to hold a button and back up with a trailer . thanks no luck yet for a down load for the manual for a 2004 600 sportsman
 
1 - 9 of 9 Posts
Top