Polaris ATV Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Has anyone found a company that make guards for the axles or the a arms for the new arched arms?
 

·
Premium Member
Joined
·
140 Posts

·
Moderator
Joined
·
8,953 Posts
Yep, Ricochet it where its at. Go ahead and get the footwell guards too (or the full set) if you run any woods, brush and rocks. Sticks will try to come up through the footwells in thick stuff.
 

·
Registered
Joined
·
37 Posts
I went with Baltic. They are the plastic version, they are very beefy. Seems like either way is a good choice, just depends if you want aluminum or plastic.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
37 Posts
Yeah, bought mine through “off road body armor”. Really cool guy. He’s a distributor for iron Baltic.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
268 Posts
Ya I did the Iron Baltic too. Front and rear a arm guards. On my 1000. Not the full skid plates. Very happy with the product. If I can find some pics I’ll post em for you later.
 

·
Registered
Joined
·
268 Posts

·
Registered
Joined
·
5 Posts
Did your rear gaurds fit very tight around the A arms ? I've installed my front ones but not the rear yet the front fit perfectly but the tears seem very tight.
 

·
Registered
Joined
·
268 Posts
Did your rear gaurds fit very tight around the A arms ? I've installed my front ones but not the rear yet the front fit perfectly but the tears seem very tight.
The rear does fit tight. I forget but you have to put 1 piece on before the other in the rear. Once in the correct spot they go on easy.
 

·
Registered
Joined
·
11 Posts
Thanks for all of the information you've shared already. I received my Iron Baltic A-Arm guards for my 2018 xp 1000 today and have the front guards installed no problem. The left rear "inboard" guard doesn't seem to want to just go in, I have to force it in to have it fit against the rails. Did anyone else experience this? Would anyone share any pictures of the guards installed in the rear? The instructions left a bit to be desired. Thanks!
 

·
Registered
Joined
·
11 Posts
Thanks very much, Owee, I'm running into the same thing. Right side fit just fine, left side wouldn't just slide in like the right.
 

·
Registered
Joined
·
37 Posts
Been a bit since I done mine. I remember they were tight and had to make sure you were putting the right part in the right place.
Never had to shave anything though


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11 Posts
Thanks Duston. In looking at how they are made, I'm sure the tolerances aren't super tight but that's speculation on my part.
 
1 - 18 of 18 Posts
Top