Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I picked up an 08 sportsman 500 ho with a winch and plow setup this fall. I used the winch a few times and I noticed ever so often the solenoid/control under the right front fender would click and not release the winch cable. I took it all apart, cleaned and sprayed everything with WD-40 to keep moisture out and clean contacts. It seemed to work well with ever so often it clicking but then would engage the winch. Now I have used the bike to plow my 40x20' drive way a few times and I noticed tonight that the speedo needle and gauge would flash and show a battery (assuming low battery light from high demand on winch and battery plowing) and as I was using the plow ever so often it would click but not drop the plow. Also when I tried to start it tonight the starter would turn over a few times then disengage then try again.

Do you think it's just in need of a good ride to charge the battery? I have heard of a few guys claiming that short driveways will empty battery's and make the winch inoperable because it runs off the battery power and not the actual engine.

Any feed back? Thanks guys!
 

·
Registered
Joined
·
192 Posts
How olds the is battery? Check volts first step should have at least 12.5 with machine off. Running at idle should be 13.4

Also might want to check volts at winch solenoid as they also do heat up and go bad

Sent from my SPH-D710 using Tapatalk
 

·
Registered
Joined
·
27 Posts
Also might need to use a battery tender.
 

·
Registered
Joined
·
192 Posts
Set parking brake machine in natural/park key off hold override turn key on. Scan through till you see volts start machine

Sent from my SPH-D710 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I need to check the age on the battery. It came with the bike. Thanks for the input guys I will try these tips tomorrow
 

·
Registered
Joined
·
101 Posts
I picked up an 08 sportsman 500 ho with a winch and plow setup this fall. I used the winch a few times and I noticed ever so often the solenoid/control under the right front fender would click and not release the winch cable. I took it all apart, cleaned and sprayed everything with WD-40 to keep moisture out and clean contacts. It seemed to work well with ever so often it clicking but then would engage the winch. Now I have used the bike to plow my 40x20' drive way a few times and I noticed tonight that the speedo needle and gauge would flash and show a battery (assuming low battery light from high demand on winch and battery plowing) and as I was using the plow ever so often it would click but not drop the plow. Also when I tried to start it tonight the starter would turn over a few times then disengage then try again.

Do you think it's just in need of a good ride to charge the battery? I have heard of a few guys claiming that short driveways will empty battery's and make the winch inoperable because it runs off the battery power and not the actual engine.

Any feed back? Thanks guys!
My 2013 Sportsman 400 does the same thing when I plow and use the winch.
 
1 - 7 of 7 Posts
Top