Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 96 polaris sportsman 400 4x4. I have to charge the battery every time I ride it, its a new battery. The battery discharges when its running and when it sitting in the garage. I can't figure out what's pulling all the power. I don't know if I should replace the stator or the rectifier. Anyone ever have this problem? Please help
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
30 Posts
Welcome to the forum!

Just a thought, do you have an on/off switch for a winch that energizes a relay/solenoid? Mine has a simple toggle switch that energizes the relay/solenoid but is wired to the key switch. If the key is turned on and off, I can hear the solenoid "click" but if yours isn't wired through the key, it could be "hot" all the time weather the key is on or off.

Just something to consider! Good luck and let us know what you find!
 

·
Registered
Joined
·
4,243 Posts
First , see if its charging, youll need a multi meter, start it, revit up a little, should have 13.5-14-5 volts at battery. Usually it the Regulator located in front of radiator
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for the ideas of what to look for. Today I used a multi meter on the battery, when started it read 12.41 when I turned on the headlights the multimeter dropped from 12 v to 10 volts in about 30 seconds and kept dropping. The regulator would probably be the problem rite??????
 

·
Registered
Joined
·
1,360 Posts
Did you rev it up some as Russ said?

Won't charge at idle...at least not too well.

Sean
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Yep I reved it up and it stayed the same at 12 v, till I turned the headlights on and the volts dropped like a rock. I just took my battery off just to make sure the battery is not bad and charged it up to 100% took it off the charger hooked it back up 30 min later and it was only charged at 81%. This battery is only 2 months old. A battery shouldn't drop that much that fast should it??? Figures I got it from Walmart
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Thanks to everyone that replyed. All the info helped out l replaced the battery and regulator and that fixed the problem thanks again
 
1 - 8 of 8 Posts
Top