Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
The hand brake on my 2007 scrambler 500 is acting weird, most of the time it'll work fine, but sometimes when you pull the brake lever it goes straight to the handlebar with no braking, if you let go and press again it works fine as if nothing is wrong. What could the issue be? It has fluid and I tried to bleed them but no air at all was in the system. Master cylinder or caliper?
 

·
Premium Member
Joined
·
9,773 Posts
What happens when you pull the lever and it goes to the bar?? Do you keep pulling it and then it pumps back up?? Have you tried using the foot pedal rear brake at the same time?? What happens when you press both???
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
What happens when you pull the lever and it goes to the bar?? Do you keep pulling it and then it pumps back up?? Have you tried using the foot pedal rear brake at the same time?? What happens when you press both???
After it goes to the bar I let go and squeeze again, it works fine the second time it's pulled, I don't really use the rear brake foot pedal, the hand brake operates both front and back.
 

·
Premium Member
Joined
·
9,773 Posts
Most likely the master has gone bad. Try and bleed it a couple more times. Also bleed the rear foot brake and master.
 

·
Registered
Joined
·
8,034 Posts
If you have a damaged rotor or loose wheel bearings, it could spread the pads on one caliper sufficiently to cause the first pull of the lever to simply take up the excess clearance and the second pump then applies the brakes - check for a warped, bent, loose rotor and/or wheel bearings
 
1 - 5 of 5 Posts
Top