Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
just bought a new 08 sportsman x2. don't have 25 miles on it and 3 hours. fuel mileage sucks. went through a half tank already. the ebs/adc doesn't work going down hills. takes off and free wheels unless I give it throttle like my old 88 trailboss. loud screeching coming from ? when the adc is engaged and going down hills. really sorry I bought this. wish I could give it back to polaris or at least shove up their ***. got stuck in a bog today and looked over at the wheels and the right front and right rear wheels were spinning but not the left rear. and the diff lock was pushed on . brand new P.O.S
 

·
Registered
Joined
·
40 Posts
yeah sounds like you got a 7000.00 paper weight/door stop, my dad had a 98 magnum 425 and it had no problems. his friends had sportsman 500's no probles i had 2 scramblers 1 400cc it bloew up. huge PITA, my 500 scammy didnt have problems with it. i pick up my predator 500 it fine. then i get this sportsman 500 from a dealr ride it once and all it does is messes up im pissed
 

·
Registered
Joined
·
19 Posts
I bought my son a new 500 sportsman and it runs great he can almost keep up to me on my 800 sportsman and in the muskeg he is right up there and so far no problems other than the transmition grinds occasionally
 

·
Registered
Joined
·
601 Posts
Dude take it back....and see what goes....I just bought a new one 3 weeks a 2009 sportsman 500Ho...runs like a r-ape......you spent all that money now take it back and explain to the dealer and see what their do....by the way Polaris don't get good gas mileage , from what i hear and seen somewhere between 20 to 30 miles to the gallon depending on how and where you drive it....on the pavement the mileage is much better when you start ripping in the woods or trails gas mileage goes to the basement....as for the ADC...only thing , i hear is it whines when your slowing down from a high speed with out touching the brakes....MUDDIE49:usa2:
 

·
Registered
Joined
·
52 Posts
800sport

my 800 only gets 9-10 mpg thats all I can expect from a 850lb machine, my wifes 06 500 ranges around 20mpg,as far as all the other trouble get it back and have em get it right!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
well I got a call from the dealer that it was ready!! went in to ask what they found and was informed that they "found a lot of problems" so I said you didn't find any thing specific and the owner of the shop said no! so the conversation got a little heated and he informed me "if I want to be a smart a** I can find another dealer to work on it" they put dielectric grease on the pins and checked the connections. now we have to remember this is a brand new machine out of the crate and bought new three weeks ago now, with 23 miles on it and the first time I took it up in the hills for work it failed in almost every aspect and he tells me that the connections are "dirty":Eyecrazy:. I contacted Polaris through E-mail and was sent an e-mail basically telling me to get screwed, that my dealer will handle any problems. I will sell this piece of shit and all my polaris sleds(two) and never purchase anything polaris again
 
1 - 6 of 6 Posts
Top