Polaris ATV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I’ve got an 04 sportsman 500ho( ebs idk if that matters ) Basically I trail ride with it and I’ll go up steep hills in high gear usually around 15-20mph on the way up and somtimes I’ll be going up and it will start spiting and sputtering and loose almost all power I’m pretty sure it’s spark because I’ve cleaned the carb multiple times and replacing the plug with an ngk helped some but it blacks out plugs and reaks like gas somtimes, oh it also does it when I’m going to take off after I’ve been running it a while, like only under load Really, I’m also thinking the cdi bc I’ve never seen it rev above about 5200( if I’m lucky) even if I’m going on a flat stretch of road floored, I’m still messing with it and I’d really like to hear input from maybe somone with a similar issue that fixed it or just somone with a little more know how, I’ve underestimated problems that spark can cause in the past and I’m afraid I’m doin that now, thanks for reading my book lol
 

·
Registered
Joined
·
15,220 Posts
If the plug is black after running full throttle on flat ground, the carb is jetted too rich or the air intake is restricted by an obstruction or dirty air filter. Another possible carb problem is an enrichener (choke) plunger that is not closing completely.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Ive gone through all those and I found out, after it gets hot I have very weak spark almost not visible, what could cause that? And it’s got the stock jet and I tried throwing a k&n on it from my Suzuki it’s and it ran the same
 
1 - 5 of 5 Posts
Top