Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
have a 95 polaris trail blazer 250. I'm concerned the oil pump doesn't function 100%. Can I add a small ratios of pre mix to the gas for a little security? Anyone done this.? I want to keep the pump on. Not get a block off plate If so what ratio do you suggest. Thank you in advance
 

·
Registered
Joined
·
2,980 Posts
have a 95 polaris trail blazer 250. I'm concerned the oil pump doesn't function 100%. Can I add a small ratios of pre mix to the gas for a little security? Anyone done this.? I want to keep the pump on. Not get a block off plate If so what ratio do you suggest. Thank you in advance
How many times are you going to ask the same question???
 

·
Registered
Joined
·
3,101 Posts
3 Threads same topic, Dude seriously?

You can do one or the other but NOT both, at least not that I've ever heard of. What makes you think your pump is not functioning properly? "At 100%" ????
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Yes seriously. Maybe someone in a different thread has done and they never look at this thread. And I'm not sure if it is working 100%. Cause of the age
 

·
Registered
Joined
·
3,101 Posts
250 is a 2 stroke, Does it smoke blue exhaust? Yes? Then its working fine.
 

·
Registered
Joined
·
422 Posts
I told him this on the first thread. Premix, 32:1 and call it a day. Don't have to remove pump.

Also making 3 threads only spreads info all over the place. 1 thread keeps everyone together to try to help you. Don't worry, people will see it and respond.
 

·
Registered
Joined
·
3,101 Posts
Yes, next time instead of starting a whole new thread, simply post "bump" in your original thread. Good Luck !
 

·
Registered
Joined
·
1,809 Posts
Don't worry about multiple posts on the same subject, doesn't bother most of us, pre mix at 32 to 1 will work and you can leave the pump connected just don't put oil in the tank.
 
1 - 10 of 10 Posts
Top