Polaris ATV Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 · (Edited)
Out riding n got this code. Not sure where to start or wut to do? It starts acting like it's not get gas then it's will start reving up then cuts off. Then it will start up fine n go for like 10/15min then does it again. 2020 570 sportsman permuim
 

Attachments

·
Registered
Joined
·
14,006 Posts
First guess is out of fuel or fuel pump failing
 

·
Registered
Joined
·
49 Posts
I think your problem is more the throttle switch adjustment (switch inside the black box throttle )
 

·
Premium Member
2017 Sportsman 850SP
Joined
·
2,016 Posts
Heck your throttle cable first and make sure it’s clear and not binding anywhere. Once that’s confirmed then you can try adjusting your throttle cable.
 

·
Registered
2015 sportsman 570
Joined
·
41 Posts
I have had this exact problem twice on my 2015 sportsman 570. First time I fixed it by removing the 4 or 5 wire mini plug that goes into the throttle housing and cleaning the hell out of both the female plug sockets and the male prongs. Small good condition wire brush and a mini flat head screw driver to scratch up the contact points. Plugged it in and it was fixed. Second time it was a throttle cable adjustment. The slack adjuster is located inline on the cable at the handle bar right before the throttle housing
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #12 ·
Thanks guys
I pulled that wire last nite n yes it was dirty so I cleaned it up n put some dialectic grease on it. I got get out to my buddy house so I can check it out I cant ride it where I live at.
 
1 - 12 of 12 Posts
Top