Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2005 Trailblazer. I bought a new solenoid for it but it still does the samething when using the key. You hear the solenoid click. I tried to bypass it to start it with a screw driver but it won't do nothing. I was wondering if the starter is bad.
 

·
Premium Member
Joined
·
20,001 Posts
That would be my guess, and welcome to the board! Should have tried the screw driver before buying the solenoid! But I would have done the samething!:stooges:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Oh well i bought a new solenoid for $20. How are the aftermarket starters compare to the oem. I just can't believe the price of a oem starter :shocked:
 

·
Registered
Joined
·
2 Posts
Are you sure the battery is up to par ?

I'd put a set of cables to a 12v car battery & see what happens.
If it is your starter, pull it & have it rewound @ an electrical shop for way less than replacement---Proflow
 

·
Registered
Joined
·
12 Posts
hmmmmmm this sounds to be the same with my 06 Trailblazer. I start it now with the pull cord. I just put a new battery on it and still when using the key I can't get it to start..... Going to have to wait till I have extra cash to replace this item....
 

·
Registered
Joined
·
6,903 Posts
first check the battery, load test it. that will tell you if the battery is good or bad.

and 90% of the time your old starter can be rebuilt for half the cost of a new one, and be just as reliable again. starters are very rebuildable
 

·
Registered
Joined
·
563 Posts
Did you check the starter wire to make sure it has a good connection?
 
1 - 7 of 7 Posts
Top