Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
My 09 sportsman 850 xp cooling fan seems to be coming on alot more often than it used to. I have flushed the cooling system and bleed all the air out and added blue ice to it. It never over heats but the fan is on quite a bit. Any suggestions. Thanks
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
5,304 Posts
Your question has now been logged into the queue and the next available forum member will answer you shortly. You will be given more advice than you could hope for.
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
5,304 Posts
Have you cleaned the actual outside of the radaitor fins? You need to take off the front bumper for full access. Just flushing with a hose won't do it all the corners remain dirty if you don't get access.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Have you cleaned the actual outside of the radaitor fins? You need to take off the front bumper for full access. Just flushing with a hose won't do it all the corners remain dirty if you don't get access.
Yes I had the front frame off to replace it and was able to clean it and straighten any fins that needed it. I'm wondering if the water pump is just not working efficiently.
 

·
Premium Member
Joined
·
12,312 Posts
Your going to need to go through the cooling system and check the boxes of operation!!!! Typically its a dirty rad. The best way to know is if the stream of water passing through the rad fins passes through unobstructed.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Your going to need to go through the cooling system and check the boxes of operation!!!! Typically its a dirty rad. The best way to know is if the stream of water passing through the rad fins passes through unobstructed.
Thanks I'll check that.
 
1 - 7 of 7 Posts
Top