Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
I run a uni filter and slip on big gun exhaust. My machine has been running rough intermittently. I started to diagnose the issue. I found that my fuel controller was not turning on when the machine was running. It did just fine when it was installed. I got on the phone with Dobeck and they were great. They were extremely nice and helpful. They called me back with a tech to help me trouble shoot and even stayed late so I could rip the fuel controller out and try some other tests. I touched the positive electrode to the battery terminal and the controller it would only work if I scratched it for a while against the battery terminal. Ridinagain was also very helpful as he responded to my PM very quickly and said he would get it taken care of. Both Dobeck and Ridinagain are extremely helpful and I'd buy from them again.

https://www.facebook.com/NorthernRider2013
 

·
Registered
Joined
·
5,753 Posts
Sounds like it went bad. Has a 2 year warranty on it and should be a simple exchange process right through Dobeck since you already contacted them and it sounds like they are taking care of it. If you have any issue getting it exchanges right through them, let me know and I'll help get it done.
 

·
Registered
Joined
·
190 Posts
How much power difference could u tell in ur machine with the filter, exhaust, programer? Which exhaust do u have?
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #4 ·
How much power difference could u tell in ur machine with the filter, exhaust, programer? Which exhaust do u have?
Honestly I don't think there was much of a power gain but the machine runs great and sounds even better. I run a big gun Eco slip on. Others describe it as sounding like a monster truck. You can hear the sound in our videos located in the media section.
 
1 - 4 of 4 Posts
Top