Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
it first started by indicating the battery emblem and turning off the headlights made it go out. next my wife was driving it and said the dial was flaching on and off. then it wouldn't start and the dial was flashing. i charged the battery but it still wouldn't start so i replaced the battery thinking it was 6 years old and maybe due. once the new battery was in and hooked up to a new battery minder and charged, i get NO display or any speedo assembly lights at all nor any starter. doing the troubleshooting, i have both unswitched and switched 12 volt signals to the speedo. can a bad speedo prevent the starter circuit? i'd hate to just replace one item at a time to find it was something simple.:shot:
 

·
Registered
Joined
·
563 Posts
If you are getting nothing at all(like everything is turned off)then it sounds like a ground wire loose somewhere.Will it do anything at all?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
no. ive got 12 volts to the speedo just nothing happening. vaugly suspicious since it just went to NO responce after i replaced the battery.
 

·
Premium Member
Joined
·
20,001 Posts
Fuse??
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7 (Edited)
where might they be on a 2003 Sportsman 700 twin? the service manual shows several circuit breakers and a few in line fuses, it just fails to mention where they are located.
 

·
Registered
Joined
·
563 Posts
The circuit breakers are suppose to reset themselves,but I guess it wouldnt hurt to check.Look under the seat or under the front rack for a little square plastic thing, some call it a pouch,that has a wire on each end.
 
1 - 8 of 8 Posts
Top