Polaris ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 2007 Sportsman 800 up and died today. Was running fine. Went to plug in a small portable air compressor to the 12v connection. When I did, the machine quit. No electrical at all. Tried connecting and reconnecting the battery -- no luck. Fuse appears intact. All connections appear to be solid.

Suggestions?
 

·
Premium Member
Joined
·
20,001 Posts
Is the battery OK?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yeah, the battery has a solid charge. I disconnected and reconnect it too. Good connections that aren't all gunked up.
 

·
Registered
Joined
·
421 Posts
if theres no power to nothing. id say a connection issue. but it sounds like a fuse also. invest in a test light, and start checking from the battery forward. is what id do.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Stupid question. Where is the fuse box? On looking today, what I thought was the main fuse just was just for an accessory connection. So it could be the fuse. But where the heck is it? Is it behind the ECM or jammed in there somewhere? Apparently, I can't recognize it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Got it. Problem was one of the main fuses. For reference, the fuse box is not located behind the access panel just under the pod. That's the location of the ECM. Instead, the fuse box (at least on mine) is located under a small access panel inside the front storage compartment.
 

·
Registered
Joined
·
421 Posts
yup. thats were they all are. mine is a 500 carb. so mine has self reseting. but i added a fuse box to mine where they are for the efi's
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
My older generation 500 carb doesn't have a fuse box either. Of course, it doesn't have a front storage box either. What's weird is that neither the manual nor the service book give it's location.
 

·
Registered
Joined
·
6 Posts
Stator

My sportsman did the same thing it was the stator get a wiring diagram and check the resistance in the stator. Polaris has the diagram on line free.
 

·
Registered
Joined
·
23 Posts
My 2007 Sportsman 800 up and died today. Was running fine. Went to plug in a small portable air compressor to the 12v connection. When I did, the machine quit. No electrical at all. Tried connecting and reconnecting the battery -- no luck. Fuse appears intact. All connections appear to be solid.

Suggestions?
Hi Think38, the fuse might seem intact but remove the fuse and verify that it is not burnt out in the center of the fuse. Also check that there is no shorted out wires underneath the light pod. Let me know.

I also have a 07 800 sportsman 30"mud lites with offset rims, high perf cam, airbox mods, bored throttle body, head porting, offset timing key, k&n filter, header and pipe and a small lift 15" of ground clearance lol. I don't get stuck that often, need to find deeper mud lol.
 
1 - 11 of 11 Posts
Top