Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 03 polaris predator 500. im having electrical issues. the battery has a full charge and doesnt want to start. i disconected the battery and hooked up a jumper to the battery cables and tryed to start it and it barly turns over and sounded like the starter was binding, i checked the starter and its good. cleaned all electrical connections, and the starter sylonied is clicking. what should i do.

tim cottrell
[email protected] or 951-552-0080
 

·
Premium Member
Joined
·
20,001 Posts
First off, welcome to the board!
 

·
Registered
Joined
·
8 Posts
i'm having the same problem with my 05 predator, i've replaced the voltage regulator and rebuilt the starter so far and that hasn't worked, but i also have other electrical problems
 

·
Registered
Joined
·
40 Posts
i have a 03 polaris predator 500. im having electrical issues. the battery has a full charge and doesnt want to start. i disconected the battery and hooked up a jumper to the battery cables and tryed to start it and it barly turns over and sounded like the starter was binding, i checked the starter and its good. cleaned all electrical connections, and the starter sylonied is clicking. what should i do.

tim cottrell
[email protected] or 951-552-0080
Try hooking a voltmeter on your battery and try starting it, if the voltage drops from between 12volts and 10volts, its either your battery is not holding charge or your solenoid/starter is binding.
 

·
Registered
Joined
·
40 Posts
i already did that and it instantly dropped to 5 volts but i got a new battery and it does the same thing
Im not familiar with predators but, when you hooked up the voltmeter and tried starting it, does the voltage dropped at 5volts when pushing the start button (after new battery, rebuilded the solienoid and with new regulator)? With new battery (assuming it is properly charged), It should not go to 5volts when you try starting it, unless there is a short in your wiring and the terminals will definitely be hot. Check your relays and connections, and try to disconnect other accesories (lights, etc.) to eliminate other possibilities at a time.
 

·
Registered
Joined
·
8 Posts
with the new battery the voltage doesn't drop but it still wont turn it over, and when i turn my lights on sometimes it shuts the quad off, i've heard about the predators having circuit breakers somewhere but i don't have a manual for it and don't know where they are
 

·
Registered
Joined
·
40 Posts
with the new battery the voltage doesn't drop but it still wont turn it over, and when i turn my lights on sometimes it shuts the quad off, i've heard about the predators having circuit breakers somewhere but i don't have a manual for it and don't know where they are
It sounded like a short in your wiring circuit (possibly a kill switch near your lighting switch)

I have seen where you can download a manual for the 03 predator in this forum site, im not sure if it will be the same for the 05 predator. here is the link, http://www.polarisatvforums.com/forums/atv-repair-maintenance/10064-service-manuals.html. Try this manual, it might be similar to your 05.
 
1 - 8 of 8 Posts
Top