Polaris ATV Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a sportsman 850 and the EPS just randomly quit working, the eps light is on with code 520230 / 31. I've checked all the connections including the relay and all are good. I have power at both connection to the eps motor. I bought a new battery and voltage regulator but that didnt fix it. After reading some forums I guess my next step would be to get the ecu reflashed?. Any input would be appreciated, Thanks
 

· Premium Member
Joined
·
13,725 Posts
It sounds like it's a communication issue between the EPS and ECU.
 

· Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
16,810 Posts
Welcome to the forum

Your question has now been logged into the queue and the next available forum member Gmartino100 will answer you shortly
 

· Registered
Joined
·
1 Posts
Has anyone figured the 520230 code out? Is there a possibility of the relay switch for EPS to go bad? Mine isn’t corroded or anything like that. pS light is on the dash and Powersteering not working. Any help would be great.
 

· Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
16,810 Posts
Has anyone figured the 520230 code out? Is there a possibility of the relay switch for EPS to go bad? Mine isn’t corroded or anything like that. pS light is on the dash and Powersteering not working. Any help would be great.
Font Line Window Pattern Automotive exterior
to the forum
Ball Automotive lighting Vehicle registration plate Font Gas
 

· Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
16,810 Posts
ICS CommunicationLoss of CAN between EPS and Instrument Cluster52023031
 

· Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Has anyone figured the 520230 code out? Is there a possibility of the relay switch for EPS to go bad? Mine isn’t corroded or anything like that. pS light is on the dash and Powersteering not working. Any help would be great.
I haven’t fixed mine since I made this post 6 months ago haha I’ve just been riding without power steering. But I’ve tested the EPS relay and all is good. I heard that a reflash of the ECU could fix it but haven’t had it done yet
 

· Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
16,810 Posts
You have a open circut between the back of the instrument cluster and the power steering gear box.
 

· Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
16,810 Posts
Rectangle Font Parallel Electric blue Pattern
 
  • Like
Reactions: latebird

· Registered
Joined
·
5 Posts
I just had that problem, replaced the EPS Relay and it went away. I switched the Relay with the relay for Bumper/Lights and in the next 100 kilometers I had an intermittent check engine code, 520194 which I never had before which sorta double confirmed that I had a bad relay. Switched the suspect relay with the start relay and never had the 520194 come back. Yes, I am planning on replacing the suspect relay with a new one, just hard to do out on the trail.
 
1 - 10 of 10 Posts
Top