Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,538 Posts
Discussion Starter · #1 ·
Just ordered the ez steer from superatv today. Going to install it on my 2010 550 X2 model. Reviews seem to be good so we will see. Ill keep everyone posted on the out come. Wish me luck
 

·
Registered
Joined
·
1,538 Posts
Discussion Starter · #3 ·
Is that EPS?
Yes it is electronic power steering. If your interested the website is superatv.com. The price of the kit seems to be worth it imo. Although I do like working on things. I look forward to projects, kinda like kids putting lego's together.
 

·
Registered
Joined
·
1,538 Posts
Discussion Starter · #6 ·
How much and let us know how the install goes!!


Sent from my iPhone using Tapatalk
$650.00 shipped to my door. If it works as they claim the most important part is marking you handle bars back to their original position, and positioning the eps unit. Only other flaw that I can think of is the power consumption. If it holds to my 2010 stock battery then it gets good reviews from me.
 

·
Registered
Joined
·
548 Posts
Thanks Rooskey. If it works out for you I think all put it on my 2012 400 and I'm sure the Mrs will want it on hers too!!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
385 Posts
Pictures as you go would be excellent.
 

·
Registered
Joined
·
27 Posts
Did one today on my tracked 08 Can Am and it went well. Had to oversize two mounting holes on the scoot, but no big deal. I was kind of puzzled at first as it didn't work at all with the scoot not rolling on the shop floor. My '14 850 XP works well at stand still. On the Can Am once you start rolling it does start working and really does make a world of difference over the OEM Armstrong steering. I wonder too about the power draw. It's -3 here in NE Washington right now so it will be hand and thumb warmers tomorrow the whole time. Curious to see if the stator will put out enough for the steering and the heat. I'll get a few rides on it and post up the results. Kit pieces were well built and instructions were enough to see what was needed. Could not mount the control box as listed due to winch issues, but I like it better where I have it under the tank cowling anyway. Way further put of the weather beside the tank. Looks to be quality stuff so far. EW
 

·
Registered
Joined
·
1,538 Posts
Discussion Starter · #10 ·
My kit was totally opposite. Worked well at idle or less than 5mph. Once I hit 5mph it cut off. Must be the speed sensor wire control on the different models. Did you experience any handle bar slop?
 
1 - 10 of 10 Posts
Top