Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2008 Sportsman 500 HO EFI. It keeps overheating I beleive because the fan isn't always turning on when it should. where is the fan switch located? is this the problem or something else?
:werd:
 

·
Registered
Joined
·
158 Posts
I'm also having a similar problem of overheating. Rode through some muck today and ended up stopping the fan from being able to spin. Gotta love seeing that coolant boiling in the overflow reservoir....

Besides moving the radiator onto the front rack (I have a bag there) are there any other good tips for keeping things cool?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Problem Solved

so this is what I found out was wrong (why my fan wouldn't turn on) 4 wheeler fix 004.jpg and this is what my Clymer manual calls it. The fan circuit breaker. 4 wheeler fix 011.jpg NOT the fan switch as I had been told by someone else. The original is a 10 amp (as shown in Clymer manual) however the parts guy at the dealership told me that many of these were found to be under rated which makes sense because the fuse for the fan is a 20 amp and the relay is a 50 amp. So he suggested I replace it with this 20 amp 4 wheeler fix 001.jpg It is located on the wire loom between the fan plug 4 wheeler fix 003.jpg and the fuse block and was covered by a piece of electrical tape. I had to do some digging to find it and actually pulled it up from where it was to show for the photo. I used this test light 4 wheeler fix 009.jpg to check all of the other electrical connections such as the fuse block and relays. I also used it to test the circuit breaker. Simply put power to the copper pole and check the other to see if the circuit completes. Thanks to everyone that offered suggestions. Hope this helps anyone else with a similar problem.
Kevin
 

·
Registered
Joined
·
12 Posts
what is the part number for the fan circuit breaker? or where can i pick one up at my atv is doing the same i think thanks
 

·
Registered
Joined
·
2 Posts
Im have same problem fan not working but will work on direct power i have 2012 polaris sportsman 500 where is the fan relay located or what could be the problem
 
1 - 10 of 10 Posts
Top