Polaris ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2004 Sportsman 500 4x4

I have replaced the battery, the fuel system is good, turned the key and checked the breaker packs with key on and while cranking on and they are not getting hot so assume they are good. I have no way to test the CDI module, the regulator, the kill switch or the key switch.

Prior to this issue, I had problems with the headlights intermittently going off and coming back on. I replaced the light switch but the problem is still around.

Do you have any suggestions that might fix the problem?
 

·
Registered
Joined
·
2,352 Posts
Itake it ,it cranks,that means the kill switch is most likely not the problem.
The easiest thing to check ,would be the electric throttle control,on the right handlebar,pop the top off and look inside,you will see two wired contacts,and these should NOT be touching,Gap should 1/16"-1/8",and is adjusted thru the throttle cable via the adjuster further down on the handlebar.
Next you could try following the wires on the left handlebar to under the hood and disconnect a black wire,this goes to the cdi box and unhooking will delete the kill switch,if it's bad and wire is unhooked should fire,if that's the problem.
It still sounds as if you have a bad circuit breaker(for the headlights)intermittant on and off usually is a good indicator. when mine went south ,i had to leave the lights on at least 15 minutes to get the breaker warmed up enough to tell. I believe the one on the far passenger side,under the hood might be the one you should be looking at, you may also check the wiring for breaks or wear going up the steering column,right at the bottom of the speedomter mount.
 
1 - 3 of 3 Posts
Top