Polaris ATV Forum banner
1 - 8 of 123 Posts

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
Sounds interesting 馃
 

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
I like YouTube links...
 

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
So today I began to peice together the blower setup and I actually got it to run under boost! The most I saw was 10lbs before the Bov opened and began to vent pressure. The engine did survive 10lbs without a problem so soon I鈥檒l add dome pressure and see if I can get 15-20lbs out of it! View attachment 173169
View attachment 173168
Yay, you finally cut the drive pulley shaft to length. (That was killing me.) LOL
How does it sound, n/a versus 10#? Any videos?
 

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
Anyway.... I found my screws did not work for holding the rotors to their shafts. I replaced them with bolts.I ran the quad for about 15minutes, and no strange sound arouse. Tomorrow I鈥檒l pull the spark plug and look at the piston for any signs of detonation and move on from there. The engine does run well with the blower on now, and I do have hope for it being blown. I鈥檒l have a video posted on YouTube shortly. Don鈥檛 mind it won鈥檛 have audio View attachment 174619
A couple questions come to mind:
"Balance" of the rotors, now that they have a bolt through them, have you felt any extra/new vibrations? (Too early, bearings haven't warn yet? Lol)
Why not put a "key" in them? (Limited machining access?)
 
  • Like
Reactions: Joint Performance

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
I did some testing over the weekend and after about 3hrs of runtime the blower steadily made less and less boost untill it was making just 5lbs... I tried putting the small pulley on, but I ended up just breaking off the input shaft on the blower from over tightening it... I Decided to just call it off on this blower setup. The amr300 just isn't going to work View attachment 175022
What failed / where was the psi going? 馃ぃ
 

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
Now that you've got the fairings in such on, how about a wide shot so we can see the body and the blower. ;-)
 

Premium Member
2015 Sportsman XP 1000 LE Touring
Joined
419 Posts
1 - 8 of 123 Posts
Top