Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, new to the forum.
I just bought a project 2002 Sportsman 500 H.O
My issue is the 4wd isn't working. I have it up on jack stands with the wheels off to work on. I took the hubs apart, I have one Hillard clutch that doesn't look good, has a grove worn in the back side of it.
I have power to the magnetic actuators and if I put a screw driver up to them they are magnatized, but don't seem very strong.
After cleaning everything up and putting the hubs back together I can get them to turn, but if I put my foot on them I can stop them.
So my questions are how strong should the magnetic actuators feel?
Any way to test the Hillard clutches to see if they are any good?
Thanks for any help and suggestions
 

·
Registered
Joined
·
8,586 Posts
The magnets are not very strong - they pull the armature plate to them to cause the inner Hilliard hub to resist turning which causes the rollers to move up the incline to bind the rollers between the inner and outer hubs. Those armature plates then have to rotate with the wheel sliding on the magnet faces. The armature plates are subject to wear and may need replaced. Also, a poor wiring connection can cause a voltage drop and reduce the strength of the magnetic pull. Run voltage directly from the battery to the AWD coils and see it it works that way - if it does, start cleaning connections especially grounds.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply.
I measured the impedance of the magnets and they are 33-34 ohms. From my research that is high. I've ordered new ones, and I've also ordered one Hillard clutch as one of mine is bad. We'll see what that does for me.
 
1 - 3 of 3 Posts
Top