Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Need some help in a major way. Overhauling a 2007 Polaris Ranger 700xp EFI. Rebuilt the front differential, installed both front axles, installed new front wheel bearings, new shocks and springs.
Putting it back together I pressed the wheel bearings in until seated, installed snap rings, put the hub on, and the axle shaft will not stick out enough for the washer or castle nut. This is for both sides so I’ve got to be doing something wrong. So frustrating.
What on Earth is the problem? I’ve use all Polaris replacement parts and matched them with the old parts taken off.
141417
141418
141419
AD51FA21-CF74-4949-9125-3F97DE44572F.jpeg
2FD6896C-BAE3-40B8-983F-7C4A98732646.jpeg
39D0A477-3ABC-43EF-9CAC-8F4D87FFF9E3.jpeg
 

·
Premium Member
Joined
·
1,943 Posts
Something just don't look right with the angle of that axle on your last picture???
 

·
Premium Member
Joined
·
10,380 Posts
Hub doesnt look like its in all the way.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hub doesnt look like its in all the way.
Need some help in a major way. Overhauling a 2007 Polaris Ranger 700xp EFI. Rebuilt the front differential, installed both front axles, installed new front wheel bearings, new shocks and springs.
Putting it back together I pressed the wheel bearings in until seated, installed snap rings, put the hub on, and the axle shaft will not stick out enough for the washer or castle nut. This is for both sides so I’ve got to be doing something wrong. So frustrating.
What on Earth is the problem? I’ve use all Polaris replacement parts and matched them with the old parts taken off. View attachment 141417 View attachment 141418 View attachment 141419 View attachment 141417 View attachment 141418 View attachment 141419
Figured it out. Half of the old race bearing was still stuck on the hub on both sides. Cut them off. Good to go. Thx!
 

·
Premium Member
Joined
·
10,380 Posts
Cool beans!!!
 

·
Moderator
Joined
·
11,164 Posts
LOL... Oh yeah! Forgot to tell you to look for that.
Its pretty common for the outer bearing race to stick on the hub.
Glad you found it.
 
1 - 7 of 7 Posts
Top