Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
Long story short, '04 sportsman 500 awd is not working. I drained and replaced the fluid but still no go. Took switch apart, cleaned it, contacts look good. I've troubleshot my way to to the hilliard coil wire connector under the pod. Have 23.5 ohms across the coil and I have 12v on the red but also fluctuating voltage on the brown wires. Somehow there is stray voltage feeding from somewhere into the ground wires. There's 2 browns going to one pin on the connector but can't tell where they come from. Would it work if I just run them straight to a ground? Thanks!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #2
After some more reading it looks like maybe they come from the speedometer? It seems these have a tendency to go bad and cause this issue. I see there is a big plug with a lot of wires and a smaller one with only a few wires. Any idea which one is the actual speedometer wires?
 

·
Registered
Joined
·
3,096 Posts
bump for FZ
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Thanks fuse! I packed it in for the night. It's down to -5 deg in my garage . Back at it tomorrow. Lol
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Does anyone have a pic of the wiring diagram for the pod section? Mine has the digital screen like the '05 I believe.
 

·
Registered
Joined
·
7,464 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Pretty sure I've ruled out electrical problems. Tried grounding the brown coil wire straight to ground. No go. Everything else seems to work, 12v to the coil, 23.5 ohms resistance, speedo works, awd indicator comes on and off, shows awd is on in diagnostic mode, gear indicator is correct for selected gear. I'm now thinking it's something in the hilliard, cage or armature maybe. My buddy said everything worked and obviously it doesn't so he's going to foot the bill!
 

·
Registered
Joined
·
4,243 Posts
If you have 12 volts at plug into front diff, time to tear diff apart, could be cracked cage, warped armature plate .
 
1 - 10 of 10 Posts
Top