Polaris ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My polaris 500 ran fine last winter. I wore the battery down today and it runs but not right. I cleaned my K&N air filter thinking ill start their then i see gas leaking out the little hose at the bottom of the carb. I shut the fuel off and am wondering where to start. I am wondering if the float is stuck or is their a piece of dirt in the needle and seat. Does the carb have to come off to clean and repair. Also sometimes bowl screws round off b-4 releasing. Has anyone had this symptom. Thanks
 

·
Registered
Joined
·
176 Posts
Welcome to the forum! Hope you enjoy it!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yes it runs out onto the ground while the quad is running or if the quad is not running. The fuel stops running when the fuel valve us turned off. The motor loads up and also has poor idle eventually dying.
 

·
Registered
Joined
·
1 Posts
carb leak

i have identical problem with mine you have to let me know what fixes it. i think the float is stuck also looking for a diagram for the top half now that i have that out. email to curleylj at yahoo dot com or call me at 3216156590 any help would be appreciated.
 

·
Registered
Joined
·
3,420 Posts
Remove the carb and clean it and inspect needle seat.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the boards!:amish:
 

·
Registered
Joined
·
309 Posts
yep clean the carb...and the screws on the bottom rounding off has happened to me a couple of times on other peoples stuff... just remember that the carb is not a head it doesnt need 50 ft #'s or anything.. You new that since you must of dealt with it also...welcome to the clan
 
1 - 11 of 11 Posts
Top