Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter #1
My sending unit is not working (gauge reads empty when tank is full) and I suspect that the float is fuel soaked and needs replacing. I have had no trouble with the fuel pump, fuel pressure regulator, heat related problems, etc., but want to know if I should replace these while I am into the tank even though they are not currently presenting a problem.

I have seen and read the great thread by AKStew regarding the procedure.
 

·
Registered
Joined
·
806 Posts
With that low of mileage and no other problems I wouldn't replace the pump. If you take the tank out put some heat reflective insulation on it.
 

·
Registered
Joined
·
393 Posts
I had the same thing happen on my 09 800. It wasn't the float mine was the contacts of the sending unit were wore out, all mine did after a while was blink fuel. I ended up changing the whole pump, regulator, and sending unit all in one. I figured if I was going through ripping all that off it was worth the $200.00 to not have to do again. This way everything is clean and new.
 

·
Registered
Joined
·
337 Posts
Discussion Starter #4
Where did you buy the whole pump/sender assembly without buying tank too? Not at the dealer I'm guessing. Can you give part #s?
 

·
Registered
Joined
·
393 Posts
I bought mine from Motosport.com part # is 2204308. I know yours is an 07 and mine is an 09 but mine also has the 6 gallon gas tank. I would believe this would still work but not sure. I do have my old one still here if you would like pictures. I looked on Polaris' website Browse but could not find a separate part for yours.


Have you checked your float put a wire or coat hanger and try to hook the float see if you can raise it up to change the level.
 

·
Registered
Joined
·
337 Posts
Discussion Starter #6 (Edited)
From what I can find, for 2007 polaris only offers the whole tank, including pump assembly, for approx $475 on up, more at the dealer for sure. In 2008/9 they started offering the pump assembly separate, but looking at the two, they each mount differently into the tank. Mine has a flat ring with several screws, and the later ones appear to have a threaded fastening ring similar to a canning jar ring.

I have no definitive information whether the assemblies interchange, even if they do mount and seal differently.

perhaps someone has tried?

Will try to hook float/rod and lift it to see if it makes a change in the gauge reading. If it does, guess it is the float. If not,......its gonna cost. At least the float is available.
 

·
Registered
Joined
·
393 Posts
Yeah mine does have just a large plastic nut that screws on so the assemblies probably are not interchangeable. That really sucks I know when I first looked they only had the full tank for mine so I didn't change it till after like a year or so. But when it slowly got down to just reading empty and flashing fuel it got real old, then I saw the pump so maybe with some digging you can find one.

Maybe even pulling out the unit and check for model names or numbers somebody has to make it if it bolts in.
 

·
Registered
Joined
·
1 Posts
Complete sendingunit for Polaris 800 sportsman 800EFI

Did you locate a complete sending unit ? I am trying to find one for a 2006 Polaris sportsman 800 EFI ? It has the metal tops screws
 
1 - 8 of 8 Posts
Top