Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hoping someone can help me out here. I just purchased a new 570 and had the dealer install the new Glacier Pro Plow to it. I got the unit home and can’t get the plow to detach. I’ve watched YouTube videos and it clearly releases right when you pull the red lever out. Is there something that I can adjust to make this work. I’ve had myself and a buddy both yanking on the thing and it won’t budge. I can see when I pull on The lever it is moving the catch bracket but it still won’t release.

Anyone else had issues with this?

Thanks!
 

·
Registered
Joined
·
5 Posts
I’m having the same problem try using grease on front hooks if you get it off cause it’s new the paint sticks manafacture says it will be like that for a few times using it
 

·
Registered
Joined
·
5 Posts
Hoping someone can help me out here. I just purchased a new 570 and had the dealer install the new Glacier Pro Plow to it. I got the unit home and can’t get the plow to detach. I’ve watched YouTube videos and it clearly releases right when you pull the red lever out. Is there something that I can adjust to make this work. I’ve had myself and a buddy both yanking on the thing and it won’t budge. I can see when I pull on The lever it is moving the catch bracket but it still won’t release.

Anyone else had issues with this?

Thanks!
Did you ever find a fix for that I’m having same problem
 

·
Registered
Joined
·
728 Posts
  1. I installed one on a buddy’s a couple weeks ago. He called next day and said it wouldn’t release, then said he pryed it and it released. I think they loosen up after a bit.
 

·
Registered
Joined
·
5 Posts
I have a 2019 Polaris sportsman 570 anyone know how many miles I can put on it before it breaks down I change all fluids as required
 
1 - 10 of 10 Posts
Top