Polaris ATV Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello all,

I'm new to this forum, and search for the problem I am having but did not find any postings.

I purchased a used polaris sportsman 90cc back in August. My son ran it for hours and it ran great. Once it got low on fuel we change over to reserve and it must have sucked up some debris from the bottom of the fuel tank. I took the carb apart and it did need some cleaning. I put everything back together and have been running it since. The problem I have now is that it seems very difficult to start and does not idle properly. Although it is not far off from the proper idle. It seems that once it is warmed up it does run better, although it still is not right. Even once it is warmed up, it is still difficult to start. The last time it ran, I had to start it on ether, even with a warm engine.

I changed the spark plug, and cleaned the carb about 4 times now. Only the first time did it seem dirty. I also jump it from the pick up, since that helps out the battery.

I have been getting frustrated with this ATV, and really want to get to the bottom of this. I am considering taking it to the dealer, although I really don't want to spend the money.

Are these 90cc engines that tempermental to start?? Any suggestions?? I thought about draining the gas and starting over with new gas. Other than that I am out of ideas.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board, and Merry Christmas!
 
1 - 2 of 2 Posts
Top