Polaris ATV Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
I just installed a QSC Clutch kit in the 850. Now its really hard to shift and especially doesn't wont to come out of low. It shifts just fine with the engine off but when you crank it up its extremely rough. Any suggestions?
 

·
Registered
Joined
·
64 Posts
Did the revs change ?
RPMs must be 1200 +- 50

Mariano
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #3 ·
It idols at 1240 just as it did stock I didnt install any shims
 

·
Registered
Joined
·
1,891 Posts
did you check to see how the belt aligns to see if its riding on one side..you may need a shim to even it out
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #5 ·
Belt looks straight. Were do the shims go ?
 

·
Registered
Joined
·
1,891 Posts
I would get intouch with ridinagain....he is the master clutch man and a QSC dealer..he will best know best what to do....
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
Thats who I got it off of I sent him a message figured some experts on here might now whats wrong
 

·
Registered
Joined
·
378 Posts
Belt looks straight. Were do the shims go ?


Agree with al53, Ryan can and will help.

As for your question though, There are shims behind the secondary clutch. When the clutch is pulled, there on the shaft next to the case. You tube videos show where they are to help you with a visual. Worked for me :)
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #10 ·
I found out I didnt align the "x" on the secondary. She is fixed now. Im very pleased with the QSC kit. I just feel like a dip shit for messing up.
 

·
Registered
Joined
·
270 Posts
Like I said in your last post, a clutch kit has no affect on your shifting of gears. One thing to note, you always have to make sure you don't lose the washers that are behind the secondary, missing those will throw your alignment off. Sometimes they stick to the clutch then fall off when your not watching, lol!!:cowboy:
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #12 ·
Ya I didnt lose the washers I just didnt align the x marks on the secondary
 

·
Registered
Joined
·
1,103 Posts
Ya I didnt lose the washers I just didnt align the x marks on the secondary
Could you tell the rest of us what that means ??

Thanks !
Each bike has washers on the front and back of the secondary; they "shim" the clutch to be direct line up with the primary so that the belt is not influenced to 1 sheave face over the other - thus creating drag on the belt which leads to excess heat and hard shifting. (he didn't lose these)

The X-marks on the secondary is in reference to the back of the secondary. Some models have "X" stamped or raised from the metal so that you can align the clutch upon re-assembly. The "X" on the helix lines up with the "X" on the secondary housing to form an "X l X" at the meeting seams to ensure proper re-assembly. (he didn't do that)
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #16 ·
Yep what he said^^^
 

·
Registered
Joined
·
274 Posts
Post some bigger pics of that 850. I have the same atv and in the market for new tires.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #18 ·
Here you go. They are gorrila x liters 28x10x14 front and rear
 

Attachments

·
Registered
Joined
·
125 Posts
Discussion Starter · #19 ·
And another
 

Attachments

·
Registered
Joined
·
1,158 Posts
Nice very nice
 
1 - 20 of 20 Posts
Top