Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2007 Polaris Sportsman 500HO EFI. Digital display shows all the fuel bars (and fuel icon) blinking on and off, along with the speedometer needle flashing red. This display is the same with or without the engine running...it's always there. It does not matter whether the tank is full or empty...same indications. I tried disconnecting the battery to reset the computer, but that did not help anything. Does anyone have any experience with this or know where to point me to start troubleshooting this problem?

Many thanks for your advice!
 

·
Registered
Joined
·
6,903 Posts
lets hope its not the fuel sending unit because that is built into the fuel take itself and if it is you would have to replace the whole tank and it is $507.81. i do not know what else it could be other then that unit
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
FYI, the fuel tank contains the fuel pump and the fuel gage sensor. The wire to the tank is under the front storage bin near the steering column. This is a 3-wire connector {Brown = common ground (-), Red = fuel pump power (+), Purple/White = fuel sensor (variable resistance)}.

The fuel gage resistance varies from approximately 5 ohms (empty tank) to 90 ohms (full tank)...measurement is taken from brown wire to Purple/White wire.

Hopefully this info can help others!
 

·
Registered
Joined
·
2 Posts
I had the same problem on my 2008 Sportsman 500 EFI. Pull the fuel pump out of the fuel tank and replace the fuel float. The floats seem to become "water logged" over time. The float is an $11 part (djtractor.com) much cheaper then replacing the fuel tank.
 

·
Registered
Joined
·
143 Posts
Thanks for the info. My guage has never worked (used quad) and lately has been blinking the more I use the machine.
 
1 - 6 of 6 Posts
Top