Polaris ATV Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I bought this machine and January and haven't really had a chance to ride it however my first ride was this weekend and was running fine for the first part of the day and on my way home I started having a bit of a zipping noise by my break right foot , and kind of sounds at the flywheel and when the throttles pushed past half and the motor starts to work or going down the road and I punched the throttle it has a really loud slapping knocking noise and the front of my motor . I took it back to the dealer the clutch is good , the noticed the noise and contacted polaris and was told to leave it and ride it till something breaks ,
I couldn't ride the quad when I first got it cause I got into a snowmobile accident and had to have surgery. And I don't want to blow this brand new machine up and have it lock up on me going down the road or have something blow through and hit me. Me and a friend both bought the same machine same time . His has no problems. When you open it up the knocking is so loud it's kinda scares the hell out of you and everyone I riding around me can hear it loud and clear from there machines . I don't wanna blow up a new machine and don't want me or anyone else to get injured if something happens . Any suggestions would be greatly appreciated. Ontario Canada
 

·
Registered
Joined
·
2,054 Posts
Find a better dealer. That's pretty bad advice

Sent from my MB886 using Tapatalk
 

·
Registered
Joined
·
60 Posts
Is the 570 a twin cylinder? Has it lost power. If the first two are yes sounds like a bad wrist pin or a broken connecting rod But don't "ride till it breaks" you will have to walk home.
 

·
Registered
Joined
·
1,912 Posts
is this a real story Polaris would never say that
and you don't say what you have go back to the canned ham site
 

·
Registered
Joined
·
482 Posts
If that is really true and nobody ends up helping, I'd duct tape the throttle with it it in park and red line it until it blows
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
The mechanic was going back and forth with polaris and the mechanic said that polaris has documented that I'm having an issue. And I have extended warranty on the machine. So if anything happen's. It will be fixed. But it is kinda a satiety issue at this time and why should I have a brand new machine with an obvious issue. I don't ride much maybe 300 miles a year, I farm and use it there and a bit in the trails when I get free time. That's why I buy new. A machine will last me 5 years with only 1000miles on it. And I don't wanna blow it up or have something let go at 60 mph .
 

·
Registered
Joined
·
260 Posts
drain the oil?
look for metallic bits,probably will have some because it is still breaking in.
but if it had a lot I would pour the oil back in and take it back
 

·
Registered
Joined
·
308 Posts
I don't see what your engine size is other than a single cylinder as you stated. But! I have a 2012 550 and under hard acceleration in the mid range it sounds like the piston is going to come out. This is a common theme with the 550 Fuji motor as many other people have commented about it also. It does not seem to affect the performance and I have not had any problems.
 

·
Registered
Joined
·
1,103 Posts
is this a real story Polaris would never say that
and you don't say what you have go back to the canned ham site
I don't see what your engine size is other than a single cylinder as you stated. But! I have a 2012 550 and under hard acceleration in the mid range it sounds like the piston is going to come out. This is a common theme with the 550 Fuji motor as many other people have commented about it also. It does not seem to affect the performance and I have not had any problems.
Since it is in the 570 section of the forum, safe bet is it is a 570 sportsman. Which have had issues already of the timing gear spinning on the camshaft.

...so to hear that his has a "knock" is not too surprising, but agree with others, find a DIFFERENT dealer!
 

·
Registered
Joined
·
2,054 Posts
Maybe ask the dealer if Polaris would also like to pay for all of you medical bills and the time you miss from work when it locks up on you going 45 mph or climbing a hill!
Has the dealer even looked at it? This is not something you should have to deal with.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #16
That is totally what is sounds like the timing gear on the cam. Good call . And that was gonna be my next move is to tell the to message polaris and see if someone gets hurt or injured are they going to pay all my bills. . Ether way this is going back to the dealer tomorrow and staying there . And I'm gonna mention to them about the timing gear slipping on the cam. Thanks everyone for the input this is my first time posting anything online. .
 

·
Registered
Joined
·
2,054 Posts
10-4. Let's us know what comes of it.
 

·
Registered
Joined
·
3,096 Posts
Good Luck !!!!
 

·
Registered
Joined
·
53 Posts
I wish the cause of the problem was posted. I am having the same slapping sound when high rpm power5200+ maybe?)is being used. Idle there is no slapping.

just got done new crank and piston installed. Edit- about 70 miles into rebuild, and noise sounds like from the front
 
1 - 20 of 27 Posts
Top