Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi Everyone,

I recently upgraded from a 2005 Sportsman 700 to a 2014 Sportsman 850 w/ the Glacier 3 plow set up. My question is specific to the Glacier 3 mount plate, the Glacier Pro Plow Mount Item #2879632.

The mount fits flush to the undercarriage but the bolts do not seem to hold the plate flush to the undercarriage piece. Welding it is a concern due to the front tire suspension arms potentially rubbing or hitting the mount plate. Can anyone provide installation instructions for the mount plate on the 2014 Sportsman 850, or can anyone provide a picture of theirs installed?

Thank you very much, I appreciate that this community is here and hope to find some help!
 

·
Registered
Joined
·
3,230 Posts
I can't comment on the glacier set up, but my mount Plate sat uneven because of the factory skid plates. I used a couple washers to space it out and make it level. More so it wouldn't snag anything while riding.

Maybe toss a few pics up so we can see what you mean.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the feedback. Attached are some pics of the mount plate, the undercarriage without the plate, and holding the plate to the chassis. The picture of the bolt hole alignment is at the base of the mount plate which is the middle of the machine.

I appreciate the prompt response, thanks again.
 

Attachments

·
Registered
Joined
·
7,464 Posts
Have you tried mounting it up to see how it fits? Sometimes things actually fit better/into place when bolted up solid and not attempting to test fit them over existing fasteners. :dunno:

From the pictures it looks like a plow mount to me..... an add on component, not a "like a glove" fit always!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I have not mounted it up yet. I am fairly paranoid on this type of thing so I would prefer to find some instructions or a reference to go off of first. Because the bolts don't sit at a flush angle, I am wondering if anything needs to be removed in order to get this thing mounted the right way.

Thanks again for the feedback.
 

·
Registered
Joined
·
593 Posts
I have a Glacier III on a 13 850, my mount looks like the one in the link below, not like the one you show.

[ame]http://www.amazon.com/Polaris-Sportsman-Glacier-Mount-2878229/dp/B005IZ4652[/ame]
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
That one looks like the front holes specifically will align better, so I will start to research that a bit more. Thanks for the link, this is helpful.
 

·
Registered
Joined
·
7,464 Posts
Have you contacted the dealer to see if you have the correct mounting plate #? I think that may be a good starting point.....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
The dealer was actually a used car dealership, so they really had no clue. I got a smoking deal on the machine as it only had 60 miles when I got it. I can call a dealership but Talon's help yesterday might have me on the right track.
 

·
Registered
Joined
·
7,464 Posts
The dealer was actually a used car dealership, so they really had no clue. I got a smoking deal on the machine as it only had 60 miles when I got it. I can call a dealership but Talon's help yesterday might have me on the right track.
Okay..... sorry my mental telepathy must not be working, as I didn't know you didn't buy it from a powersports or Polaris dealer. :D :fing02:

My thought (maybe a little better explained....) was to call your local / nearest Polaris dealer to see what the correct mounting plate number was and/or what your plate number fit.

Good Luck, I hope you figure it out soon.... snow season is just around the corner! :stupido:
 
1 - 10 of 10 Posts
Top