Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I own an 04 Predator 500, like new, I'm the original owner, runs great! I recently bought a 03 Predator 500 that had been sitting outside for 4yrs as a project bike. Transmission was stuck in first gear, so i split the cases, got the main shaft changed and while I was in there I decided to do all the seals, some bearings, new rod and wristpin bearings, and also upgraded to a Weisco 12.5:1 piston and rings. Also I bought a carb rebuild kit from Shindy since the carb was full of green stuff and rebuilt carb. Put all the air fuel stuff back where it was before i started. Also took the fuel pump apart and cleaned it really good.

After everything was back together the bike starts and idles like a champ! But when i snap the throttle it dies right away but will start up just fine. Doesn't matter if the bike is cold or warm. I have the needle set where the factory one was. I don't know much about carbs to know what to do here. Mods are only the 12.5:1 Piston, K&N Filter, and stock pipe with baffle removed.

If anyone could please help it would be greatly appreciated!! Also I'm looking for a good set of grey or orange front plastics too if anyone has anything!
 

·
Registered
Joined
·
19 Posts
I had this same problem with my '03, I had to clean out my carb, but I found I missed just a little piece of dirt in the jet I either missed or added during the clean out. it just took taking it apart again. Another Idea, if you have all that green crap in the carb, what about the tank, fuel lines and shutoff switch? You might not be getting enough fuel To the carb to do much more than idle.
good luck
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
5,753 Posts
Check the throttle safety switch and you may need to double check the carb. Pilot does the idle circuit, main comes on at about 1/4 throttle. Check the rubber bellow on top of the slide carefully for rips or holes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
yeah i flushed the tank and all the lines before i put the carb back on.. Rebuild kit came with all new parts jets and all. I know i got to get the floats adjusted correctly since it leaks out the overflow but I'm gonna take it back apart and see whats up with it and see if i see anything.
 
1 - 5 of 5 Posts
Top