Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Hey everyone, I'm out at camp for deer season, and I got my bike off of my truck last night. I have a 2004 330 magnum 4 x4. I went to go to the blind this morning, started it up, pushed the brake pedal to get it out of park, but the shifter won't budge. I tried everything. Any suggestions?
 

·
Registered
Joined
·
3,417 Posts
Sorry to hear you are having trouble while trying to go huntin. Try the brake lever on the handle bar, or rock the atv back and forth it may be in a bind. The linkage may be bent.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #4
well, an update... I ended up having 2 quarts of water in my gearcase that was frozen, dirt in the bearings of the front differential that tore it all to pieces, and a myriad of other things wrong. New axle shafts, axle joints, the magneto that engages the 4x4, basically a whole new front end on a machine that i rode maybe 3 times since i bought it in september. thankfully i have a friend who is just going to charge me for the parts, so instead of a thousand bucks, the damage will only be about 450 bucks...
 

·
Registered
Joined
·
745 Posts
This is the first time I've seen your thread, but my immediate thought was water in the gearcase. Glad you got it figured out. Now you've got to find out where the water was coming from. Something's leaking.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
well, on top of the seals being bad, i had a little mishap trying to power my way through a swamp to get to my deer blind this fall, i got hung up on a tree that was under about 3 feet of water... not good! that is where i'm thinking the water came from
 
1 - 7 of 7 Posts
Top