Polaris ATV Forum banner

1441 - 1460 of 1499 Posts

·
Registered
Joined
·
247 Posts
Hi Blueline, You have exceeded your message storage capacity, you have to delete some before I can PM you.
I hate to say it, but the activity on this forum (and most) seems to be on the decline. Facebook is taking over but sucks for anything more that a simple answer to something.
If I had a manual, I'd be happy to share. Maybe someone put there will be able to tear themselves away from the Facebook plague long enough to respond.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
1 Posts
Hello from Custer, South Dakota. I am a new newbie to the ATV world. I just purchased a 95 Magnum 425 4x4, nice machine. My question is. The rear tires are different than what is/was speced. The spec calls for 25x12x10 and right now there are 25x11R10 on the rear, was this an option? Why change to that size tire? is it effective or would I be better off going to speced size rear tires. Thanks all. Oh and where can a guy take an ATV riding class, I'm new, not young and want to live another forty-years. Thanks all.
 

·
Registered
Joined
·
247 Posts
Hello from Custer, South Dakota. I am a new newbie to the ATV world. I just purchased a 95 Magnum 425 4x4, nice machine. My question is. The rear tires are different than what is/was speced. The spec calls for 25x12x10 and right now there are 25x11R10 on the rear, was this an option? Why change to that size tire? is it effective or would I be better off going to speced size rear tires. Thanks all. Oh and where can a guy take an ATV riding class, I'm new, not young and want to live another forty-years. Thanks all.
Hey ski6687,
I can't think of any good reason to go to narrower tires. In fact, with the stock rims and making the tires narrower is just looking for catching bark and dirt in your tire bead. This will result in constantly having to reseat your tires on the rims to fix slow leaks. Considering the age of the machine, the previous owner probably just got a good deal or picked up some used tires.

As far as riding classes, never heard of them in my area. But then there isn't really anyplace legal to ride either. I started riding in my early 40s and I'm 53 now. I have no intention of stopping anytime soon. My advice to you is to ride on your feet, not your seat and as long as you can stop within your visibility distance, you'll be fine. Of course, you shouldn't ride alone and take your phone with you in case you get into trouble you can't get out of.

One more thing, If there's the remotest chance you'll get wet, put your phone in a ziplock bag. Most of all, Have fun!


Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
4 Posts
I'm a newbie. I have a 2005 ATP 330. I seem to have an over-voltage problem that shuts off my instrument cluster to protect the electrical system after a few minutes at idle. I have a fully charged battery. Every thing shuts down. I need to know how to re-set it. Can anyone give me a step by step fix? We have a ton of snow and I need to plow us out.
 

·
Registered
Joined
·
17 Posts
Newbie to 4 wheelers. but not maintenance, my oldest son /we are being given a Green Polaris Xplorer (maybe a early '00's? 250 4x4 with Robin engine) but no clue yet as model number or engine but some picks he sent with it partially dissembled. Is it okay to post the pics to get help ID'ing it in this thread?
Robin engine ID tag:
EC250PFE150-5085
Ser 016142
 

·
Registered
Joined
·
4 Posts
Re: you rpost

I'm not familiar with the model Polaris you have. I've only owned the 2005 Polaris All Terrain pickup (atp). It's had a few problems over the years, but you expect some maintenance expense. We've probably spent about a $1000 during that time for repair. Now we may be looking at another thousand if two or more spendy parts have to be replaced. I think we spent about just over 6k for it new. We like the Polaris, I like the way it handles when it is running well; it has nice features, but we have reached the point of diminished return. I have an experienced mechanic evaluating it right now trying to get at the bottom of my problem. If there is no manageable work-a-round we will probably decide to be done with it. As my son Bryan says, at this age you have to expect key elements to break down. He says we have paid for a high end 4-wheeler with spphisticated bells and whistles and maybe that wasn't so smart. One replacement part is estimated at about $450 and another about $350 and they both could be bad. In fact it may even involve needing to replace both of those parts plus the display module as well. This is worse case, but we can't do it. Some of the older models, without the fancy electronics, may actually be a better choise. You might want to do a little research on the maintenance cost history for the 4-wheeler model you now own. It could be a simpler, less costly model to own and fix up than what I'm dealing with. (Good advice, I wish I had done this research before I brought this baby home). Oh well. Good luck.
 

·
Registered
Joined
·
1 Posts
po;aris rzr 4 800 robby gordon

my rzr had a cluch kit put in and now it wont switch into high gear will only go 40 and will not switch to go faster any body have any thoughts on what my be wroung
 

·
Registered
Joined
·
495 Posts
my rzr had a cluch kit put in and now it wont switch into high gear will only go 40 and will not switch to go faster any body have any thoughts on what my be wroung
Check the belt tension and idle speed. Too much tension/rpm will cause hard and often grinding gear shifts. I think, any spacing should have been taken care of while it was still apart. Will it go into High with the engine switched off?
I am very old school so, I personally would see if it would go into gear with the engine off and that should tell you if the initial setup is too tight and may need a small spacer. Again, I think it needs to be torn down to install any spacers. Good luck!!!
 

·
Registered
Joined
·
4 Posts
Hey, I have a 2010 550 and the eps only works idling and driving slowly, it gives a battery warning and eps light, I have already checked the battery voltage, driven with a booster on the battery and the eps still doesn't work, I also changed the rusty corroded eps relay, but to no avail, eps still only works at low rpms...
 

·
Registered
Joined
·
3 Posts
new first time polaris owner

I just got my first Polaris ATV today. Upgrading from a 2007 Suzuki kingquad. I purchased a the 2017 sportsman xp 1000. I noticed a small hose hanging down on the bottom left of my machine. Its right behind the left front tire, I'm guessing its probably a drain of some sort. I traced it back as far as I could see and it seems to be coming from the display/front headlight area. The only reason I question what it is is because there is a small plastic nozzle on the end that looks like it should be plugged into some other hose or component. Just wondering if anyone more farmiliar with Polaris could ease my mind about what it is, and more importantly, is it supposed to be attached somewhere else or just a drain with a plastic nozzle on the end......Thanks in advance for any insight you can give.
 

·
Registered
Joined
·
116 Posts
I just got my first Polaris ATV today. Upgrading from a 2007 Suzuki kingquad. I purchased a the 2017 sportsman xp 1000. I noticed a small hose hanging down on the bottom left of my machine. Its right behind the left front tire, I'm guessing its probably a drain of some sort. I traced it back as far as I could see and it seems to be coming from the display/front headlight area. The only reason I question what it is is because there is a small plastic nozzle on the end that looks like it should be plugged into some other hose or component. Just wondering if anyone more farmiliar with Polaris could ease my mind about what it is, and more importantly, is it supposed to be attached somewhere else or just a drain with a plastic nozzle on the end......Thanks in advance for any insight you can give.

It is just a breather hose and that plug looking thing is a filter. I can't guess what one it is as there are a few that normally trace their way up there then loop around the gas tank fill hole (not sure of proper name) under the shrouding that is over your gas tank. Prob best just to tuck it up or re- run it so it is not pulled on or damaged as you use your new machine. More then likely it's the breather hose for your front diff.

Here is a website that has helped me over the years on identifying and locating parts.

http://parts.polarisind.com/Browse/Browse.asp




Soup
 

·
Registered
Joined
·
3 Posts
breather hose.....

Thanks for the reply sp.campbell. I traced that hose a little further and it goes up to the area under the instrument cluster/front headlight, the other end of it I found had the same nozzle on it as well, also not connected to anything. Also there was a bundle of 3 more band tied together and stuffed into the area behind the top headlight. I'm guessing they are some breather tubes from elsewhere on the machine. Almost looks like the one with the nozzles on both ends was put there for possibly some option that could be installed later, I dunno. So far I'm liking this quad, its got more power under it than any other ive ever owned. Just trying to get used to the one brake lever operating front and rear brakes simultaneously AND the throttle by wire set-up.......anyway, thanks again for your help man!
 

·
Registered
Joined
·
5 Posts
I need wheel and tire conversion help for a sportsman

:pedro:
First if you are new here, we most certainly welcome you! If you are a lurker right now, (and there are a lot of you lurkers out there) dont be shy, sign up!

I thought i would post this thread to help new people who do not know any members and might have a question, to help who the best person on this forum might be to personally address the question, or bring their attention to a certain thread.

feel free to post a thread about any problems you might have, as we all learn from those. but this thread will hopefully give you an idea who to ask for help from.

existing members, if you have any speciality skills that you wouldn't mind sharing and helping new people with, post those up here!

i'll start....

I have a few years of polaris parts experience and sales experience too. I also have special access to the dealer site. Most of my knowledge is on the newer machines. I can help with parts and sells with all models polaris (atv's, sideXsides, snowmobiles, and watercraft) i have installed almost every accessory in the polaris book at one time or another. i have also done a lot of "little" service shop stuff, but nothing major. but being behind the parts counter, i felt like a service guy a lot of the time.

if you have any questions that releate to:
-sales purchasing
-rebate help
-sales fees/discounts
-VIN# runs for possible recalls
-Accessory install help
-Part # help/cost
-Find a part #
-What parts fit what years and models
-Maintenance Questions
-General Service Questions

if you have a question even close to any of these topics, please feel free to PM me at any time. I will do my best to help you out, or point you in the right direction.

who else has special skills that they can offer help on?
 

·
Registered
Joined
·
15 Posts
Hi...

Peace and love Peace and Love.
First timer.
1999 250 trail boss- I got two of the same unit.
The clutch is making a knocking sound when I put a load on the machine when pulling a heavy load.
I am always pulling a trailer full of stuff around the farm.
I live in the Smoky's on the side of a mountain.
The sound is not there when I ride on a flat surface but when going up hill with just me it will knock... but going up hill with a load, man o man it knocks HUGE!
It don't seam to heart it none?
Could it be the drive clutch unit connected to the transmission needs to be rebuilt?
By rebuilt I mean the spring replaced? 7041198
Or could it just be that I am abusing the poor thing?
How do I put an ID picture into my profile?
Poote
 

·
Registered
Joined
·
1 Posts
Brakes No Bleed

2005 Sportsman 500 HO. Front brakes seized up. Released pressure opened bleed valve. Couldn't get brakes to bleed, replaced master. Brakes still won't bleed. HELP:smashfreakB:
 

·
Registered
Joined
·
1 Posts
Hey guys new to the forum. I have a 07 sportsman 800. Just picked up a glacier pro plow and the mount that Polaris told me I needed. According to the instructions it just mounts right up to the frame and that's that. I'm scratching my head bc without mods to the frame this thing does not line up!! Help!
 

·
Registered
Joined
·
4 Posts
2009 polaris scrambler 500ho 4x4 what other hubs will fit my axle I want to use my leftover banshee rims if possible and will the predator rear shock fit my scrambler if so what year I need a better rear shock in part to my riding and in part to im 220 lbs and the stock shock doesn't like my lbs and riding style mixed any help is greatly appreciated and knowledge is open to anyone that needs it my knowledge base is more racing atv and snowmobile and 25 years as a mechanic and heavy equipment operation
 

·
Registered
Joined
·
6 Posts
I purchased a 2017 sportsman 850 touring sp. I've been to the dealership once with idling issues and some 84 codes but those issues were solved by plugging in the speed sensor which had come unplugged. Test rode it at the dealership and it was great, back to brand new.

After I got home with it, I go to start it up and bring it off the trailer and low and behold the check engine light is on. Originally, a diagnostic code didn't even show up. But after a few on and offs it showed 520230 31: which according the the manual is an issue with the power steering.

Here's the catch, the thing runs excellent and the power steering works perfectly. I've checked all the fuses and the EPS relay, I even unplugged the EPS relay and rode it around to see the difference between having power steering and not having power steering...but I swear it still works.

Any ideas or suggestions about what's going on would be appreciated.
 

·
Registered
Joined
·
4 Posts
Hey Blueline, thanks so much, It's great to have people like you we can turn to. If you get a chance, check my post on my 850, ty so much, Krow
 
1441 - 1460 of 1499 Posts
Top