Polaris ATV Forum banner

1461 - 1480 of 1499 Posts

·
Registered
Joined
·
4 Posts
Hey Mark, I too have an 2017 850. My check engine light is on only after we took it up the mountain. Only 4.7 hours on this machine. I couldn't get any codes to come up. How did you get them to come up? I read the manual online and I swear I did what it says, but no codes come up. Thanks, Krow
 

·
Registered
Joined
·
7 Posts
Hey guys, I am new here. I recently purchased a 98 magnum 425. The bike runs like a top. It starts like a dream. Always fires right up, first try. The problem is, it only goes 30mph. I have seen guys get theirs to 50 and heard others say theirs would do 60. My bike is absolutely gutless in high. We have done a few things to trouble shoot. We have removed the throttle stop. We have removed the muffler. I replaced all of the fuel lines... none of these things made any difference. Something interesting, the bike can be throttled down 50% and it will achieve all it can do with 50% more throttle travel completely unusable.

I have a new drive belt on order so that might make a difference, I wouldn't be surprised if it still has the original belt in it. I don't think it is in the drive belt because it revs to the same rpm in neutral as it does in drive.

Does anyone have any thoughts about this or can you direct me to someone who does?

Thanks
 

·
Registered
Joined
·
7 Posts
Hey guys, I picked up a 89 trailboss 250 for my daughter to ride. It was in rough shape but I got it running really well. Here's my problem..it runs really rough when the battery is hooked up and no power to any lights, dash brake nothing. The starter switch does work and it fires up everytime. I'm not sure if it's the lighting coil and what wires to check for it, and or what wire would be my main power to he the lighting. Any help would be great. Thankyou.
 

·
Registered
Joined
·
3 Posts
Hey folks, I am new to the forum. Just bought a used "new to me" 2006 Polaris 800. The owner I bought it from has the Mudzilla tires on it and I don't care for the really rough ride at slow speeds. I would like to stay with an aggressive tread and don't mind some "roughness" at slow speeds, but not to where it is so rough it jerks the steering from side to side. Any tire brand recommendations and what is the biggest size I can install on stock suspension?
 

·
Registered
Joined
·
1 Posts
I have a 2008 Polaris 500 h.o. it starts fine but after running for a while the service engine light comes on. And it gets sluggish and dies. If I let sit for 30 or minutes it will start and run for about another 30 minutes. Not sure what it is? The battery is putting out 14.1 when driving if that info helps. Thanks in advance Jamea
 

·
Registered
Joined
·
5 Posts
Hello. New to forum. I have a 2003 700 sportsman with a bad trigger coil. It reads open with an ohmmeter. What should the ohm reading be on a good trigger coil? And do I have to pull flywheel to replace it? Easy enough to get to but wires run behind flywheel. Where do you guys recommend best place for parts. OE polaris parts pretty pricy. Thanks!
 

·
Registered
Joined
·
1 Posts
2015 Sportsman ETX

Started ok ran 200 metres then spluttered out. wait restart.. 200 metres splutter stop. and so on

Where is fuel vent ?

Fuel is new, flattened the battery so that's on charge. Backfires now. has had a lot of mud recently.

How hard is it to take off the top plastic cowling over fuel tank?

Spark plug..out of sight, need to be a midget to get to it, needed to take front wheel off to get battery out, but still fond of my polaris... have lot more trees to plant.
 

·
Registered
Joined
·
100 Posts
thank you for the insight. I just purchased a 2002 expedition 425 that needs work. I want to start with all new fluids. Can you tell me what to use in the front and rear diff? also what to use for tranny fluid?
 

·
Registered
Joined
·
1 Posts
first if you are new here, we most certainly welcome you! If you are a lurker right now, (and there are a lot of you lurkers out there) dont be shy, sign up!

I thought i would post this thread to help new people who do not know any members and might have a question, to help who the best person on this forum might be to personally address the question, or bring their attention to a certain thread.

Feel free to post a thread about any problems you might have, as we all learn from those. But this thread will hopefully give you an idea who to ask for help from.

Existing members, if you have any speciality skills that you wouldn't mind sharing and helping new people with, post those up here!

I'll start....

i have a few years of polaris parts experience and sales experience too. I also have special access to the dealer site. Most of my knowledge is on the newer machines. I can help with parts and sells with all models polaris (atv's, sidexsides, snowmobiles, and watercraft) i have installed almost every accessory in the polaris book at one time or another. I have also done a lot of "little" service shop stuff, but nothing major. But being behind the parts counter, i felt like a service guy a lot of the time.

If you have any questions that releate to:
-sales purchasing
-rebate help
-sales fees/discounts
-vin# runs for possible recalls
-accessory install help
-part # help/cost
-find a part #
-what parts fit what years and models
-maintenance questions
-general service questions

if you have a question even close to any of these topics, please feel free to pm me at any time. I will do my best to help you out, or point you in the right direction.

Who else has special skills that they can offer help on?
i just got done doing a bottom and top end on my 1987 trail boss 250 4x4 i bought this thing dirt cheap and it was sitting for 30 years. Everything seems to be in order exept. The shifter plate that hold the shifter in gear was loose i have been messing with it trying to get it in the right possition how ever it will seem like it pops out of gear.
I will be riding and all of a sudden the thing feels like some one put the rear brakes on hard. I will pop it into n and roll it back and forth then put it back into the either h or l and it will be ok for a few yards then again will feel like some one is on the brakes. I have flushed the gear box/trans as it was really bad. Put 70w90 in it. My question is will the wrong fluid do this or is it my loose shifting plate by the fender causing this. Any help would be appriteated. Sorry for the bad spelling and gramer. Let me know if i need to run somthing diff in it or if i need to tighten the plate. I have tried to tighten it while it feels good but it still will feel like brake is on. I know its not the brake as it will move freely in n pleaes help!!
 

·
Registered
Joined
·
16 Posts
New member here. Don't have any problems with my machine. It's an Xplorer 400, year 2000, bought it new. About 800 miles and going strong. I use it at my hunting camp and at home in the backyard. I've been looking for a snow plow setup for it this week, but gave up amid the confusion of part #'s and varying prices for the same items. I'm going to keep looking in the used parts listings locally until I can find something that fits my machine without doing all kinds of modifications. Hopefully I'll find lots of interesting reading here on the forum. Merry Xmas and Happy New Year.
Duane
 

·
Registered
Joined
·
43 Posts
Hey guys newbie here, I've owned a Polaris now for about yr, still glad i bought it, but i do have an issue with shifting only when its running, I've trimmed the spring and that helped a little, and I know this is an old topic, just curious if anything new has come up thanks, sportsman 850 xp/ho
 

·
Registered
Joined
·
117 Posts
How do I post pics? Please explain it in simple terms so I can understand it. I tried to drag from my pics on my laptop. No go. I tried copy and paste from my laptop. No go.
I dont want to use photo bucket so dont suggest that.
I dont use apple products so dont go there either.
Thanks in advance
 

·
Registered
Joined
·
2 Posts
Left front tire on sportsman 400 leaned in at the top

Hi Guys,
I am hoping that someone might be able to help me. I recently bought an older (1997) Sportsman 400. The problem is the left front wheel is leaning in at the top about an inch or so. I don't know much about the suspension on atv's. If someone could give me an idea of someplace to start I would be thankful.
 
1461 - 1480 of 1499 Posts
Top