Polaris ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
862 Posts
Discussion Starter #1
though i would post a video of my low beams after installing some cheap HID's. they are temporary, i will replace them with something better if they crap out but i wanted to see if i would like them. needless to say i am looking for a ballast and bulb for the high beam lol. install is painless, any kit will be plug and play as long as you get it for the right bulb. forgot to take pics of the install but they are tucked up under the inspection cover for the radiator.

ill be posting the video of my $10 10watt led back up light soon.

 

·
Registered
Joined
·
3,096 Posts
Do these need to "warm up" when the ambient temperature gets really cold? When its cold out Ive seen that issue with some HID's where they are super dim when initially turned on then they slowly warm up, or else just don't turn on at all. Only curious, looks good bro!!!
 

·
Registered
Joined
·
862 Posts
Discussion Starter #3
ya takes about 45 seconds to reach full output, and about 20 to reach useable output. the video makes it a bit hard to tell because its trying to keep the exposure even.
 

·
Registered
Joined
·
3,096 Posts
That's not bad, the ones ive had experience with took a full 2 minutes to warm up.
 

·
Registered
Joined
·
862 Posts
Discussion Starter #6
i ordered 5k bulbs, but they look closer to 6k to me. either way they are ok, i just wouldn't go any higher in snow conditions.
 

·
Registered
Joined
·
862 Posts
Discussion Starter #8
this gives you a better idea what they look like when you are actually using them. i was testing out my camera while i was checking to make sure my plow was set high enough to not take a bunch of gravel with it.

 

·
Registered
Joined
·
2,846 Posts
That's not bad at all. Brighter than I expected.
 
1 - 11 of 11 Posts
Top