Polaris ATV Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
My 2012 550xp quit while running and there is no fuel pumping and fuel pump wont come on and there is power at the red wire on the pump for a few seconds when the key is initially turned on.
what is needed to remove the fuel pump. before I start taking everything apart? I pulled the ring off but nothing will clear the frame to get even the ring off.
Thanks for any advice.
 

·
Registered
Joined
·
4,243 Posts
I would think if you remove the filler neck and 2 bolts that hold the top of tank uou will get some movement to remove the pump, book says to remove front plastic, right hand footwell, then remove tank, I havent had to do one of the xps yet,.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #4
Thanks Russ C,
exactly like you said. slide it over enough to get the pump straight out.
the pump is definitely getting power and not running.
Do you know if the only option is to buy the pump kit from polaris? I am in Costa Rica and will try to get it at the only dealer, but I had read about other guys buying the pump from an auto part store. The whole unit with sender unit and all is some contraption.
Any more ideas on easy pump replacement?
 

·
Registered
Joined
·
4,243 Posts
Carter # P72118 at auto parts store, These fit the 7-800's I think they will work on the xp.s take your old one with you and compare.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #6
thanks.
I would like to take the pump out of the assembly, not even sure how to do it, but it is such a crazy looking contraption with small plastic tangs holding it together I am afraid I'll destroy it. When I calm down a bit I'll sit down with it again.
 

·
Registered
Joined
·
4,243 Posts
Can you take pictures, I can see if I can help, cant believe they are much different than on a 800 or rzr, oh Here is the # for pump in rzr, is the same style of tank, Airtex #8335
 

·
Registered
Joined
·
91 Posts
Discussion Starter #8
I am so worn out by emotional crap an this(no reason to really be) so I didnt want to disassemble this thing and break it, but I will try so to get the pump out. here is picture of the whole unit
thanks so much
 

Attachments

·
Registered
Joined
·
91 Posts
Discussion Starter #9
Ok, here I put a close up of the white plastic piece that seems to be holding the bottom housing to the top housing. I cannot see how this can be removed. the top pieceof the white plastic is holding the black housing as the metal rod goes thru it and the bottom part would need to slide off to the side as its on tracks.
I hope you follow me. there must be a way or its known not to be possible as they may have pressed the rod in after the fact.
I am sure I am not the first to deal with this.
Thanks again
 

Attachments

·
Registered
Joined
·
91 Posts
Discussion Starter #10
so I had to break the white plastic ear (ring) that went around the rod, only way to get it apart.
I couldnt believe the corrosion on the soldered connections on the pump. the pos side corroded totally away, thats why it stopped pumping, no connection.

So the pump is a bosch has a few #s on it s06 110-19 other # is 03133001
made in china
I hope to find this here in Costa Rica,
by the way the bike has only 2 months 16 days on it. warranty would have run out day before it failed, but as I am in CR to get Polaris to do the right thing would be impossible. I just want to get it to run.

Any idea what car would use this pump so I could have them look it up that way?
 

Attachments

·
Registered
Joined
·
91 Posts
Discussion Starter #11
I looked at the pic of the carter p72118, looks different as you can see from the photos. the pick up side for the screen is much smaller on mine and the top(outlet) is different too. Mine as you can see from the first photos in the early post seems to connect into a regulator.
anyway, I hope to know another automotive application so they can maybe get it here, I will pay the huge $$ if they have it at the dealer here which will be about $400.
 

Attachments

·
Registered
Joined
·
4,243 Posts
did you check the other number off the Rzr? Sorry but I havent had to do a xp yet so I havent had to do all the cross-reference . maybe someone else has? Anyone?
 

·
Registered
Joined
·
575 Posts
try an early 90's hyundai sonata, I think thats what it crosses to. Goin off memory so I may be wrong
 

·
Registered
Joined
·
91 Posts
Discussion Starter #14
thanks Sean. Yes I saw on this or another forum that someone said it was for a Hyundai, but the 2012 and maybe a few others are different. I looked at those pump photos and no good. thanks though. I think I will just buy it here in CR for $500, crazy I know but I gotta get it running and then when in the states get the right one at an auto parts and have the spare.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #15
thank you

just a thank you to you guys who helped comment while I was solving the fuel pump replacement.
I did buy the new fuel pump from the Costa Rican dealer(price hurt bad at $470) no help from polaris even though it was within warranty(they are not friendly for this), its a complete assembly with sender, regulator, filters etc, a real contraption, but easy install. less than an hour to put it in and put all the panels etc back together.
So thanks again
 

·
Premium Member
Joined
·
9,943 Posts
140317
 
1 - 17 of 17 Posts
Top