Polaris ATV Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I have a 2014 sportsman 570 EFI, I have a love hate relationship with it. Love it when it's running, hate it when it's not running!
I have been able to use this forum to get the job done so far... but the time has come. I need a person (real) to help me. I need a good honest person to help me find out what's wrong with my 4wheeler!
Hoping this forum can help me find a mechanic in my area, Fowlerville Michigan. At this point I have given up, I just don't have the time to sit and watch how to videos anymore!
 

·
Registered
Joined
·
18 Posts
Hey. I don't see myself visiting Michigan any time soon but if you want to show me your other thread I can potentially offer some insight. What's the machine (not) doing?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I don't blame you for not wanting to visit Michigan (gov is jerk) but it's a beautiful state! The list of problems is long... replace fuel pump back in march, replaced battery,(3 months ago) new spark plug (yesterday). It won't stay running! I jump start it, it starts, stalls I turn the key... nothing! It will run for a bit but keeps stalling!
 

·
Registered
Joined
·
18 Posts
I don't blame you for not wanting to visit Michigan (gov is jerk) but it's a beautiful state! The list of problems is long... replace fuel pump back in march, replaced battery,(3 months ago) new spark plug (yesterday). It won't stay running! I jump start it, it starts, stalls I turn the key... nothing! It will run for a bit but keeps stalling!
When you say jump start it, do you mean using a battery booster, or do you mean manual start with pull cord?

How long is a bit?

After it stalls, do you have spark at the plug?

After you removed the old plug, did you notice if it was dirty at the bottom?

This could be one of several issues, or potentially multiple issues. Did the bike run right at sone point, or did you buy it like this? If it was ok, can you describe the circumstances surrounding the failure?
 

·
Registered
Joined
·
248 Posts
I have a 2014 sportsman 570 EFI, I have a love hate relationship with it. Love it when it's running, hate it when it's not running!
I have been able to use this forum to get the job done so far... but the time has come. I need a person (real) to help me. I need a good honest person to help me find out what's wrong with my 4wheeler!
Hoping this forum can help me find a mechanic in my area, Fowlerville Michigan. At this point I have given up, I just don't have the time to sit and watch how to videos anymore!
Hey I'm right next to you. I'm in Pinckney.
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
7,492 Posts
  • Like
Reactions: pcaster

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
7,492 Posts

·
Registered
Joined
·
248 Posts
Would you recommend C&C in Brighton? Don't know if she'd want to take it to Full Throttle in Diamondale.
I did have some warranty work done on a Sportsman 1000 and it took C&C a long time to complete- 5 or 6 weeks. This was pre- COVID in January 2020. It’s hard to find a reputable place. I would go back to them if I had to. I really like Leaders RPM towards Kalamazoo but that’s a treck to get there.
 

·
Registered
Joined
·
248 Posts
Hows the FORD doing?
It’s still at the dealer. They finally pulled their heads out of the sand and dove into as they should have the 1st time. They pulled the trans. and are changing lots of parts. It’s been there all this time waiting on parts. They finally got the last part they’ve been waiting on Friday. They agree whatever happened shouldn’t have.. . I’m happy to say it’s on its way out. As soon as it’s complete it’s getting traded in on a new 2021 Ranger Lariat. The Edge was bought for my child’s mother. I’m the primary owner but it’s her vehicle. I use it to pull the toys when I go riding. The loaner she has is a new Ranger Lariat and she likes it. By Wednesday of next week the Edge will be in the past! I have a new Explorer on order that will be the toy puller next year. I will use the new Ranger for the rest of this year after it gets its initial 500 miles on it. My huge hillbilly truck isn’t practical at all to pull the toys so that’s a no-go!
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #13 ·
Hey I'm right next to you. I'm in Pinckney.
I did have some warranty work done on a Sportsman 1000 and it took C&C a long time to complete- 5 or 6 weeks. This was pre- COVID in January 2020. It’s hard to find a reputable place. I would go back to them if I had to. I really like Leaders RPM towards Kalamazoo but that’s a treck to get there.
I wouldn't take it to C&C...
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #16 ·
When you say jump start it, do you mean using a battery booster, or do you mean manual start with pull cord?

How long is a bit?

After it stalls, do you have spark at the plug?

After you removed the old plug, did you notice if it was dirty at the bottom?

This could be one of several issues, or potentially multiple issues. Did the bike run right at sone point, or did you buy it like this? If it was ok, can you describe the circumstances surrounding the failure?
Battery booster to start it, No pull cord on it, it ran for 5 or 10 mins (few laps around the property). I had spark when I turned the key once, second time I turned the key... dead. when I changed the plug it was black at the end. I have had it for several years I bought it from family (perfect shape) everything went south after I put in the new fuel pump back it march of this year. My thought lead me to a failed fuel pump again...
 

·
Registered
Joined
·
41 Posts
I would take it in if they are good and not to expensive. I would also not take it to C&C
That I don't know. I always took my motorcycle for servicing at Capitol Harley across from Full Throttle Motorsports. My only interaction with FTMS was ordering my 570 and a few phone calls. Other than that, I know nothing of them.
 

·
Registered
Joined
·
137 Posts
I don't blame you for not wanting to visit Michigan (gov is jerk) but it's a beautiful state! The list of problems is long... replace fuel pump back in march, replaced battery,(3 months ago) new spark plug (yesterday). It won't stay running! I jump start it, it starts, stalls I turn the key... nothing! It will run for a bit but keeps stalling!
Battery booster to start it, No pull cord on it, it ran for 5 or 10 mins (few laps around the property). I had spark when I turned the key once, second time I turned the key... dead. when I changed the plug it was black at the end. I have had it for several years I bought it from family (perfect shape) everything went south after I put in the new fuel pump back it march of this year. My thought lead me to a failed fuel pump again...
Does the check engine light come on when it stalls. If so have u looked for any diagnostic codes on the display?
 
1 - 20 of 33 Posts
Top