Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Ok, since i have never had an atv vehicle before I have this question.

I have a 97 polaris xplorer 300 4x4 that I just made it come back to life (thanks to this website). Question is does the 300 engine use oil/filter since I dont see a filter or a dipstick to check the oil? I do see a dipstick but is on the back part of the engine so im guessing is for the transmission.

What oil does it use on the oil reservoir in front of the chassis? and is that the only engine oil I have to check?

Please help me as to what lubricants I need in order to not make the engine go kaboom because I didnt add oil to the engine.

Thank you.
 

·
Registered
Joined
·
527 Posts
The oil tank for the injection oil is up front and it has a low oil warning light on the dash when the machine is low. It is always a good idea to check the oil and check and synchronize the oil pump. There is and in line oil filter right before the oil pump. The dipstick you are referring to is for the transmission.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Thanks dirty dawg.

So the oil up front is for the gas/oil mixture. But the engine itself does not have any oil to check right? I just wanted to make sure. They told me it ran like the weedeaters and they do not run with oil in their engines. Is that true about my 300 engine?

Thanks in advance. I just dont want to be having fun and then the engine blow up because I didnt look far enough to check the engine oil.

Thank you.
 
1 - 3 of 3 Posts
Top