Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an early model 2004 Polaris Sportsman 700 ATV which has a malfunctioning instrument display cluster and all wheel drive system. Some gear shift icons are not displaying properly but more important the all wheel drive is not engaging properly in low and high gear positions.

When the gear shifter is engaged in neutral position the N icon is not displayed but the machine is actually in neutral - engine revs and the machine does not move.

When the gear shifter is in the low position the L icon is displayed but the all wheel drive does not engage unless the yellow instrument button on the left handle bar is pressed.

When the gear shifter is in the high position, the N icon is displayed and the all wheel drive will not engage even when the yellow button on the left handle bar is pushed.

When the gear shifter is in the reverse position, the R icon shows and all wheel drive works as normal by pressing the yellow button on the left handle bar. (Of course for all this checking, the all wheel drive switch on the right handle bar is in the 'on' position.)

Last fall before I put the bike away for the winter, the all wheel drive was working ok but when the gear shifter was in the high position, a L icon showed on the instrument cluster. The all wheel drive was working when the all wheel drive switch was in the on position and the gear shifter was in the low or high position. Reverse worked ok as well.

Any suggestion for a fix, or for where to clean connections would be great.
Thanks
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:wavey:
 

·
Registered
Joined
·
221 Posts
If your speedo doesn't work your 4wd will not work. I had the same problem on my 01 sportsman what I did was on the back of the speedo there is a plug that has 6 wires in it I spliced into the 2nd wire in from each side and ran them to a water proof switch now I can still use 4wd I just have to flip 2 switches. I hope this helps. A new speedo for my quad is over $300
 
1 - 4 of 4 Posts
Top