Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone. I have an intermittent issue that I haven't found anyone describing. I bought a 2005 Polaris ATP 500 a few months back. a handful of times so far I have shifted into reverse and the engine revs up and just as the machine is about to start moving, the motor throttles down. It doesn't stall or die. You can hold the throttle wide open and the engine just cycles up and down. I haven't noticed anything odd with the speedometer (since some people say it bounces up and down). The last time it happened, I pressed the override button and it reversed like it should. So does anyone have an idea what could be happening? Thanks for your help!
 

·
Premium Member
Joined
·
9,925 Posts
Theres an rev limiter for reverse, sounds like it's working. The reverse over ride button also will engage the AWD in reverse as well as override the Rev limiter.
 

·
Moderator
Joined
·
10,665 Posts
Sounds like its working the way its supposed to. You have to press the reverse override to have full power and AWD when in reverse. Its a safety feature to keep you from killing yourself.
 

·
Registered
Joined
·
8,494 Posts
Perhaps the belt is worn out or the primary clutch need serviced since you have to rev the engine that high to get it moving?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for the replies. To Be clear though, the engine doesn't rev real high. I don't have decreased power. The engine revs up and down sometimes. It does this up to a point before the clutch engages then revs down. But it doesn't do this everytime. Maybe next time it happens I can remember to make a video. Thanks everyone.
 
1 - 5 of 5 Posts
Top