Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
https://db.tt/bK8IyaV9



Put this thread on nyroc but i wanted your guys opinion also.

King quad shakes when under load. I was trying to pull out a frozen playground airplane
I had it in 4 Lo i was only giong about 2 mph all 4 tires were spinning and digging in the ground.
 

·
Registered
Joined
·
1,206 Posts
what year is it? I no some 09 750s would crack a right side rear motor mount. or the bushings/ rubber piece could wear out. This is first I have seen one shake that bad! I have found king quad build is right next to built proof. I would take off the floor board and check the mounts on it, also the bolts on motor mounts tend to shake free more on big singles then the twins, its BIG time problem on Honda 680s and 500s around here.
 

·
Registered
Joined
·
326 Posts
Discussion Starter #3
2013, i called my dealer and said it could be the mounts or a loose bolt. Im giong to drop it of at the dealer tomorrow and everything is giong to be under warranty :biglaugh:. 355 miles and 60 hours on the quad. Only downside is that its giong to be there for about 2 weeks becuase of the holidays.
 

·
Registered
Joined
·
2,980 Posts
2013, i called my dealer and said it could be the mounts or a loose bolt. Im giong to drop it of at the dealer tomorrow and everything is giong to be under warranty :biglaugh:. 355 miles and 60 hours on the quad. Only downside is that its giong to be there for about 2 weeks becuase of the holidays.
I don't think you need an excuse to ride your 850, so just enjoy it while the Kawi is in the shop
 

·
Registered
Joined
·
3,096 Posts
whoa.....usually Suzuki's are pretty stout machines. Must just be bad luck my friend. Good Luck at the dealership!
 

·
Registered
Joined
·
326 Posts
Discussion Starter #6
2013, i called my dealer and said it could be the mounts or a loose bolt. Im giong to drop it of at the dealer tomorrow and everything is giong to be under warranty :biglaugh:. 355 miles and 60 hours on the quad. Only downside is that its giong to be there for about 2 weeks becuase of the holidays.
I don't think you need an excuse to ride your 850, so just enjoy it while the Kawi is in the shop
Its actually a suzuki :veryhappy: . It snowed about 8 inches and my 2WD nissan titan got stuck in the snow, i got my 850 and pulled her right with no problem :fest06:
 

·
Registered
Joined
·
326 Posts
Discussion Starter #7
whoa.....usually Suzuki's are pretty stout machines. Must just be bad luck my friend. Good Luck at the dealership!
Thanks, i think it was a factory defect maybe a new guy was in the job when it was made.:cowboy:
 

·
Registered
Joined
·
3,096 Posts
^Damn high school drop outs
 

·
Registered
Joined
·
326 Posts
Discussion Starter #9
:rotflmao: good thing its gonna fixed .
 

·
Registered
Joined
·
326 Posts
Discussion Starter #10
Update

I got the bike from the dealer last saterday. They told me it was all normal. They said its normal becuase the engine is under a load the motor has to shake. I called another dealer and a mechanic gave me a 15 mins explenation on the phone why the engine shakes. So its normal :shocked1:
 

·
Registered
Joined
·
805 Posts
Thats completely normal for King Quad 700s and 750s. Head over to Nyroc and look up the M109R engine mounts install, and upper engine mount mod. Still have your dealer check it out but they probly wont find anything to fix.
 

·
Registered
Joined
·
326 Posts
Discussion Starter #12
The dealer did check it out, they even grabbed a 0 mile machine same as mine and put in gear with brakes locked up and also shaked. I did the upper mount "bump stop" and it did help with the shaking.
 
1 - 12 of 12 Posts
Top