Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just bought a 98 Magnum 425 for $1k. Its in great condition but the lights wont come on. Any ideas on how to fix or where to start? This is my very first ATV and I love it. Also, the exhaust has melted a small portion of the body panel.... about a 2" square. It doesnt affect the ride....jut doesnt look like I want it to. any ideas on where to get a replacement body panel?
 

·
Registered
Joined
·
3,417 Posts
Just bought a 98 Magnum 425 for $1k. Its in great condition but the lights wont come on. Any ideas on how to fix or where to start? This is my very first ATV and I love it. Also, the exhaust has melted a small portion of the body panel.... about a 2" square. It doesnt affect the ride....jut doesnt look like I want it to. any ideas on where to get a replacement body panel?
The contacts in the switch are probably corroded. Try electronic cleaner or take the switch apart. Being very carefull not to loose the small springs and the small steel ball about the size of a bb. Maybe this will help. Thanks
 

·
Registered
Joined
·
1,664 Posts
Just bought a 98 Magnum 425 for $1k. Its in great condition but the lights wont come on. Any ideas on how to fix or where to start? This is my very first ATV and I love it. Also, the exhaust has melted a small portion of the body panel.... about a 2" square. It doesnt affect the ride....jut doesnt look like I want it to. any ideas on where to get a replacement body panel?
Welcome! First, make sure you have power coming to the switch(look for a fuse). Then, make sure you have power going the lights. You can check these things from the battery or from the lights (by elimination). Don't know if you want new plastic or not, but you might try partshark.com. Hope this helps.
 

·
Registered
Joined
·
20 Posts
i know it sounds stupid but did you check the bulbs? sometimes when you pull start these they will blow all the bulbs on the quad.
 
1 - 6 of 6 Posts
Top