Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2012 polaris 500 HO
60 hours

I have two sons which have been riding the quad, and are oblivious to the problems i recently encountered on my trip around the property. This is why i cant have nice things...at least thats what my dad used to say to me.I changed the spark plug, and made sure it was in high gear.

*Max Speed is 25 MPH
*Backfires at Top speed when letting off throttle
*When letting off throttle, has a hard "engine brake" effect.
* starts, idles fine, runs normal at low speed
*Heats up quickly, after driving for three minutes, muffler was very hot
* no codes or instrument cluster warnings.

I thank you all in advance for your time, attention, and help. I will pay your kindness forward.

paul.e
 

·
Registered
Joined
·
1,181 Posts
Belt slipping?
Bad clutch?

My bet would be timing.
 

·
Registered
Joined
·
5,753 Posts
I would guess a belt and/or clutch issue for the lack of top speed and hard deceleration. IF it has EBS it will decelerate harder than the non-EBS version. The backfire letting off the throttle could be simply an adjustment of the throttle cable. Maybe the safety switch is momentarily making contact when you let off? The hot exhaust could be a lean condition or normal depending on your definition of hot.
 

·
Registered
Joined
·
2,412 Posts
Does it start backfiring when you get to high revs? If so then you are hitting the rev limiter because the buttons are shot in the secondary clutch. It will max out a about that speed because the secondary can not open wide enough. It will also get very hot because you are working the motor at full load.
 
1 - 5 of 5 Posts
Top