Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 08 sportsman 500 HO EFI bought new in May 08. I have roughly 16 hours as I have only used this for hunting and plowing this year. Just went to ride with some friends when all was well until the bike made a chatter then stopped. We found the oil reservoir located behind the front left wheel was split and had drained out. I assume the bike has a safety feature that shuts it down when oil pressure drops. We towed the bike to camp and removed the oil tank, called to see if we could get one and it wasn't stocked. Knowing i had to replace it we tried sealing it so the day wasn't wasted. We sealed it and added oil and the bike fired back up but has a knocking at idle and upon acceleration. Has anyone else had trouble with this oil reservoir? Also, why don't they make it out of plastic or place someplace with more protection? Does anyone think I could get Polaris to warranty this? I appreciate any help you can offer.
 

·
Registered
Joined
·
527 Posts
Sounds like you will need a piston or some crank work. There is no low oil sensor that will shut the machine off. Talk to your dealer and see what they say. Yes the plastic oil tank is a piece of crap, if you look up a 2000 sportsman 500 it will have a very nice aluminum tank. This tank has a right and left hand sides and a gasket in the middle along with the bolts to assemble it. If I remember right the oil lines hooked up in different between the two. I have seen several plastic tanks fail but have never had any issues with the aluminum one. If you can not get it warrantied give me a call 651-340-1129.

Good Luck

Dale
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have a shot of hope left. While reading the manual about the oil I noticed that if you discinnect the oil line you will need to reprime the pump. Seeing that it wasn't knocking when it shut down it may be as simple as repriming. Took it to the dealer this morning and explained the situation and they took a quick listen, had me leave it there and they want to take the valve cover off and oil it up before speculating. Waiting to hear back. Poor design on the tank though. If I do not get any satisfaction I will be calling you.

Joe
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Looks like that's just what I got. Definite motor damage. Going to try calling Polaris along with the dealer to see if there is some way they might cover it due to a design flaw. It's worth a shot. Also have the dealer working on a trade for a sweet 08 leftover.
 

·
Registered
Joined
·
441 Posts
hey dirty dawg , go back n read his post .sounds like he has a metal one . his quote , also why don t they make it out of plastic ........i have a plastic one on the scrambo , no probs from that yet .
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Sorry guys I posted that wrong. It is made out of plastic and what I meant to say is why don't they make it out of metal. Either way, being plastic and where it is placed is just plain insane. I cannot believe this has not happened before. As far as the damage, the dealer can only assume the worse until it is taken apart and checked out. The bottom line is I have a new machine with no hours and the motor needs to be rebuilt due to design flaws. I should hire Erin Brokovich to go after them...lol
 
1 - 10 of 10 Posts
Top