Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I got an 03 predator and it will run fine for about 15 minutes, then it dies out of no where. after a minute it will start again and be fine for about 5 minutes, again it will start but then dies at about 2 minutes and so on. If this where a car i would say maybe a bad coil but on quads.... i know nothing about these machines, any idea? obvioously its an electrical problem, something is getting hot. It has a new magnito btw oh and it also shuts down the whole bike, i mean lights and all. so could it be a breaker? I was told by one guy that polaris atvs have breakers...

thanx guys
 

·
Registered
Joined
·
18 Posts
I have had simular issues with my machine running and then randomly dying. I don't loose electrical. I did just find that the fuel tank breather line was pinched and will be taking it out this weekend to see if this helps it running.

I would love to know as well were the fuse box is for a Polaris. I have looked around and can not find one. I have a 05' sportsman 500 H.O. It would be nice to see if I blew a fuse for my handwarms.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
i thought about loking for a pinched fuelline as well. I"m thinking its probably not a fuel line since it sems to get worse as the bike heats up. BUt also i was told by the dealer service tech that the polaris atvs don't have fueses. they only have a curcuit breaker or a type of magnetic switch. I tried finding schematics here on line but they they are always little tinny pics that i can't enlarge them.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Well I figured it out, so i figured I'd post the results. Turns out that they have a magnetic switch that acts like a curcuit breaker i guess. anyway, i pluged it in backwards reducing its ability to fail, and opened it up to the air to stay cool, and it works great, the predator has not died yet after a few hours of run time.
 

·
Registered
Joined
·
8 Posts
im having the same problem with my predator, where is that circuit breaker located? i just got this thing and have no clue about it. im not new to this but i've only had bikes before without all this electrical nonsense
 

·
Registered
Joined
·
10 Posts
There are two circuit breakers on the bike one on the left side cover under the seat and the other under the front of the gas tank. These are in sealed black bags. If they are tripping and stopping your quad i recommend going through with a tester and finding the problem instead of bypassing them there, there to protect your wires and sensors.
 
1 - 7 of 7 Posts
Top